
System For Time
And Attendance
Reporting
(STAR)

Version 1.02

September 2003

TITLE I
Payroll/Personnel Manual

CHAPTER 7
Time and Attendance Procedures

SECTION 3
System For Time And Attendance Reporting (STAR)

National Finance Center
Office of the Chief Financial Officer
U.S. Department of Agriculture

Procedures

 



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

 System For Time
And Attendance

Reporting  (STAR)

National Finance Center
Office of the Chief Financial Officer
U.S. Department of Agriculture

 



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

IMPORTANT INFORMATION !

This publication is an illustrated version of STAR help . Since the user can access
and print help directly from the application, help is considered the primary source for
information about STAR.

When you print help directly from the application, the format is different from this
illustrated version; however, the text is the same. Therefore, NFC provides the
illustrated version only upon customer request.

For information about this publication, please contact the Directives and Analysis
Branch (DAB). Instructions for contacting DAB and other support sources are
provided in the About This Procedure  section of this publication.

Published and printed by the Directives and Analysis Branch
National Finance Center, U.S. Department of Agriculture

New Orleans, Louisiana
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Latest Update Information

Title I, Bulletin 03-8, System for Time and Attendance Reporting (STAR) (Windows-based)
Version 1.02, dated September 12, 2003, notified users that STAR was being upgraded.
Version 1.02 included enhancements to the (1) Archive pop-up, (2) Prepare Transmit File
window, and (3) Print Reports window. Additionally, several new edits have been
incorporated into Version 1.02.

Listed below is a summary of the changes to the STAR procedure:

Description of Change Page

Revises the Archive pop-up and entry instructions 32

Revises the Prepare Transmit File Window and entry instructions 64-65

Revises the Print Reports Window and entry instructions 67-68

Revises the Archive pop-up Field Instructions 83

Revises the Prepare Transmit File Window Field Instructions 107

Revises the Print Reports Window Field Instructions 109

Deletions in the text are identified by “* *”;  other changes are identified by “ ”.
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About This Procedure

This procedure provides instructions for accessing and operating STAR. The following
information will help you use the procedure more effectively and to locate further assistance if
needed.

How The Procedure Is Organized

The major sections of this procedure are described below:

Overview  describes what the system is used for and provides related background
information. It also provides security access information and instructions for accessing the
system.

Getting Started  provides access instructions, exiting instructions, operating features,
reports related to STAR, and the STAR menu bar.

System Maintenance  provides information regarding STAR contact point records,
instructions for establishing or changing the JCL, setting up applicable access levels for
STAR users, importing data, exporting data, converting data from PC-TARE into STAR,
backing up data, restoring data, and archiving data.

Tables  provides instructions for Application Administrators to establish and maintain
tables in STAR. STAR contains accounting code, pay period, leave type, and transaction
code tables.

Employee Maintenance  provides instructions for the Timekeeper to add, update, and/or
delete employee records.

T&A Maintenance  provides instructions for the Timekeeper to prepare Time and
Attendance reports (T&A’s).

Field Instructions For STAR Windows  provides field instructions for STAR windows.

Reference Tables  provides tables for fields with drop down menus and lists of options.

To keep you informed about new or changed information related to this system, NFC issues short
publications called bulletins or amendments. This procedure and all related bulletins are listed in
the NFC Publications Catalog, issued semiannually. Also, What’s New on NFC’s home page
(www.nfc.usda.gov) provides a list of all bulletins by title and publication date. Users can choose
to view and/or print bulletins from this list.
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What Conventions Are Used

This procedure uses the following visual aids to identify certain kinds of information:

Convention Example

Messages displayed by the system
are printed in italics.

Processing was successful.

Emphasized text within a paragraph is
printed in bold .

You must enter data in this field.

Figure references link figures with the
text. These references are printed in
bold sans serif font.

After accessing STAR, the STAR Menu Bar
(Figure 5 ) is displayed showing the STAR
Menu Bar with 5 options.

References to sections within the
procedure are printed in the same font
as figure references.

Note:  When a heading is referenced
in the procedure, you can use the
Heading Index to locate the page
number.

For instructions on this process, see
Searching For An Employee .

In instructions, menu options are
printed in bold italics .

From the STAR Menu (Figure 5 ), select
File >Employee Maintenance

References to command buttons or
keyboard keys are printed in brackets.

Click [Find]  to search for the employee or
[Cancel]   to cancel the search.

Field names are printed in the margin.
Field specifications are printed in
italics.

Note:  Field entries are identified as
required1, conditional2, optional3, or no
entry4.

SSN Required, numeric, 9 positions
Type the employee’s 9-digit SSN.

1Required You must enter data in the field. (Note: All mandatory fields on STAR screens are highlighted to distinguish1Required You must enter data in the field. (Note: All mandatory fields on STAR screens are highlighted to distinguish
required entries from optional entries. The highlighted fields must be completed to avoid rejection.)q g g j )

2Conditional You may be required to enter data, based on criteria indicated in the field instructions.y q ,
3Optional You may elect to enter data in the field. If the field is left blank, no data is system generated.p y , y g
4No entry You do not enter data in the field. The field instruction states the reason for no entry.

Who To Contact For Help

For questions about the system (including help with unusual conditions), contact Customer
Support personnel at 504-255-5230.

For questions about NFC processing, contact the Payroll/Personnel Operations Section at
504-255-4630.

For access to STAR, contact your agency’s security officer.

For questions about this procedure, contact the Directives and Analysis Branch at 504-255-5322.
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Overview

This section presents the following topics:

About STAR

Related Systems

Payroll/Personnel Processing Cycle

Responsibilities

About STAR

STAR is a Windows-based application of the National Finance Center (NFC). STAR operates
in a Windows environment requiring Windows 95 or higher, or Windows NT 4.0 or higher.
This application is used to:

• Gather data entered by timekeepers for the purpose of recording attendance and leave
and for calculating employee wages each pay period.

• Enter T&A data at any time during the pay period.

• Enter corrected/split T&A’s.

• Perform certain edits to determine if the data is correct.

• Print T&A’s to be reviewed and approved by supervisory personnel.

• Prepare T&A’s for transmission to NFC.

• Create a transmit file to transmit T&A’s to NFC.

Through the use of STAR and local telecommunication capabilities, agencies can prepare
T&A’s on their personal computers (PC’s) and transmit them to NFC for processing. T&A
transmission files are transmitted through a communication connection that the agency
establishes with NFC. NFC assigns a unique 8-digit batch number to the transmitted T&A’s
and sends back to the agency a confirmation of the number of T&A’s received. The
confirmation is a summary reflecting the total number of 80-character records, total hours,
and total transaction codes (TC’s) received.

The T&A’s are processed through the T&A Validation System (TIME) which reads, collects,
edits, audits, and validates the data for payment. All errors encountered are reflected on an
error list, and the T&A in question is placed in an error suspense file. The T&A is corrected
by NFC and is processed through TIME again. After T&A’s pass all edits and validate, the
database is updated for subsequent payment processing.

Timely submission of T&A’s is necessary because of the impact on the employee’s pay.
T&A’s should be closed on the last day of the pay period and processed as soon as possible.
T&A’s should be transmitted to NFC no later than the Tuesday following the last day of the
pay period.

Per agency request through CULPRPT, NFC provides the agencies’ T&A Contact Points
with CULPRPT Report P0099, Error Analysis For T&A Processing, generated by TIME.
The T&A coordinators also receive a cumulative statistical report of T&A’s processed.
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Agencies can obtain information concerning updates to the Payroll/Personnel database
through the Information/Research Inquiry System (IRIS) and the Payroll/Personnel Inquiry
System (PINQ). For more information about IRIS and PINQ, see Title I, Chapter 15, IRIS, or
Title VI, Chapter 4, Section 1, PINQ.

For more information, see:

STAR Users

Record Retention Requirements

Hardware And Software Requirements

STAR Users

The System Administrator establishes STAR users in the Employee System (EMCP). Once
the users are established, roles are given in the Permissions System (PRMS). PRMS is used
to assign applicable permission level(s). There are five possible permission levels. An
individual may have all five or any combination of the five permission levels. For more
information see Title I, Chapter 24, Employee System (EMCP) or Title I, Chapter 25,
Permissions System (PRMS).

Timekeeper. Allows the user to perform T&A functions; to print employee data; to convert
data from the Personal Computer Time and Attendance Remote Entry  System (PC-TARE)
to STAR; to back up, restore, and archive employee and table data and to modify the
accounting and pay period tables.

System Administrator. Creates and controls the user ID record for each authorized user;
backs up and restores files; uses the Import/Export function; archives data; and converts data
from PC-TARE to STAR.

Transmitter. Prepares a transmit file and establishes job control language (JCL).

Application Administrator. Maintains and updates tables and establishes contact points.

User Administrator. Assigns specific contact points for user access.

Note:  Also, the agency must designate an individual(s) to download/install STAR, be
responsible for safeguarding STAR at the agency location, provide guidance to users, and act
as a liaison between STAR users and NFC for STAR matters. In addition, this individual is
responsible for establishing transmission capabilities. For more information about computer
security, see Title VI, Chapter 1, Security Access Procedures.

Note:  STAR options available to a particular user are highlighted according to the assigned
roles.

Record Retention Requirements

For T&A data electronically transmitted to NFC, agencies must maintain the certified T&A
report (i.e., printout, worksheet, etc.) and all appropriate supporting documentation for a
6-year period in compliance with General Records Schedule (GRS)-2 and the General
Accounting Office (GAO) audit requirements.

NFC will maintain the personal payment history required in Fair Labor Standard Act cases
and court-ordered restorations as cited in the supplemental authorization NC1-16-79-5 to
GRS-2.
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Hardware And Software Requirements

You will need the following equipment to run STAR:

• A PC capable of supporting Windows 95 or higher, or Windows NT 4.0 or higher.

• Windows 95 or higher, or Windows NT 4.0 or higher.

• Super Video Graphics Array (SVGA) monitor set to 800x600 resolution and small
fonts.

• Inkjet printer or laser printer (with at least one megabyte of memory).

• STAR application software.

Note:  If you receive the STAR software from the Internet, by download, or on
CD-ROM, it will contain files for all operating systems. Based on your system setup,
you will choose the applicable dcom95, dcom98, mdac_typ , and Star
Setup  files in the STAR folder. Windows 95 users should use the dcom95 file.
Windows 98 users should use the dcom98 file. Windows NT does not require either
file. If you receive the STAR software from diskettes, you must first go to the
Microsoft Web site at www.microsoft.com/data to access the applicable mdac file and
at www.microsoft.com/dcom to access the applicable dcom file.

NFC will provide you with the data storage capability necessary to run STAR.

Note:  When installing STAR on a stand alone PC, the System Administrator uses the
STARSetup.exe file and Typical setup type to load the STAR application on the individual’s
PC. When installation is completed, all files required to run STAR reside on that PC. When
installing STAR for a local area network (LAN), the System Administrator uses the
STARSetup.exe file and Typical setup type to load the STAR application on a LAN server.
The System Administrator then uses the Compact setup type to load required files and
registry entries on each individual PC. When installation is completed, program files required
to operate the STAR application reside on the LAN server. The reports utility and the
database containing employee and T&A data reside on the individual’s PC.

Related Systems

Systems that are utilized by the Time and Attendance process are described below:

Employee System (EMCP). EMCP is a Windows 95/98/NT application that allows the
STAR System Administrator and timekeeper to enter employee and/or user data.

Information/Research Inquiry System (IRIS). IRIS is used as a tool for researching
personnel-related inquiries received from employees and other sources. IRIS provides
immediate access to at least 25 pay periods of current data, historical personnel data
beginning with Fiscal Year 1991, and certain payroll document history.

Payroll Processing System (PAYE). Processing continues with the application of PAYE.
Using the data entered in STAR and the related personnel information from the database,
PAYE computes the employee’s gross pay, makes applicable deductions, applies adjustments
(corrected T&A’s and/or personnel documents) from the Adjustment Processing System,
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develops the net amount due, and prepares data for the issuance of a salary payment by
Treasury. PAYE updates the database to reflect salary payments as well as the employee’s
leave. PAYE also prepares an earnings statement for all paid employees each pay period,
reflecting the current payment, plus year-to-date information on earnings, deductions, leave,
bonds, adjustments, retirement, etc.

Payroll/Personnel Inquiry System (PINQ). PINQ is used as a tool for researching
payroll-related inquiries received from employees and other sources. PINQ provides
immediate access to at least 25 pay periods of current payroll data.

Permissions System (PRMS). PRMS is a Windows 95/NT/98 application of NFC. PRMS is
used to establish user profiles for (1) NFC mainframe applications and (2) PC
applications (STAR) after users are established in EMCP.

Report Generator System (CULPRPT). CULPRPT is an online reporting system used to
generate formatted payroll and personnel-related reports. CULPRPT reports are used to
detect any errors during T&A transmission.

Statement of Earnings and Leave (EARN). EARN is an inquiry system that displays the
employee’s biweekly earnings minus any deductions. Data entered in STAR is displayed in
EARN after it passes the TIME edits.

T&A Validation System (TIME).  The initial processing of T&A’s which are entered in
STAR is accomplished through TIME, which reads, collects, edits, audits, and validates the
data for payment. All errors encountered are reflected on an error list, and the T&A in
question is placed in an error suspense file. The T&A is corrected at NFC and is processed
through TIME again. After the T&A passes all edits and is validated, the data is updated on
the database for subsequent payment processing.

Time Inquiry System (TINQ). TINQ is an online leave entry and correction system used to
update leave data that may have been incorrectly entered in STAR. It is also used to transfer
leave for employees participating in the Leave Sharing Program.

Payroll/Personnel Processing Cycle

The payroll/personnel processing cycle is the timeframe during which agencies record and
transmit employee payroll/personnel data to NFC for processing through the
Payroll/Personnel System. The cycle runs for a 2-week pay period. The payroll/personnel
cycle consists of:

• The entry and transmission of payroll/personnel data by the agency.

• The entry and transmission of T&A data by the agency.

• The processing of this data by NFC through the payroll/personnel processing system.

Note:  Front-end edits are performed in STAR and must be corrected before
transmission. At the end of the pay period, agencies transmit T&A transactions to
NFC for processing and begin recording transactions for the next pay period.
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Responsibilities

Listed below are the T&A processing responsibilities of the primary organizations involved
in processing and application maintenance.

The Agency:

• Downloads and/or installs and maintains STAR for specific timekeepers. (This
individual should have a working knowledge of Windows 95 or higher, or
Windows NT 4.0 or higher.)

• Enters T&A data for each employee, as required by law and regulations.

• Prepares a T&A data transmission file.

• Transmits T&A’s to NFC by established timeframes.

• Corrects leave errors.

• Monitors T&A related status reports and takes measures to reduce T&A rejections and
leave errors.

NFC:

• Processes T&A data within established timeframes.

• Edits T&A data.

• Reviews T&A edit error messages and corrects the T&A. Contacts the agency for
assistance as necessary.

• Monitors and notifies the agency of missing T&A’s.

• Provides reports.

Employee:

• Documents his/her T&A information on a daily basis in accordance with his/her
agency policies.

• Provides his/her T&A information to the timekeeper no later than the Monday after the
close of the pay period.

Note:  For information on the roles associated with these functions, see STAR Users .
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Getting Started

This section presents the following topics:

STAR Help

Starting STAR

System Access

STAR Operating Features

STAR Menu Bar

STAR Help

To use STAR, you must have knowledge of Microsoft Windows. Use your Windows user
guide for instructions on navigating in a Windows environment. Use this procedure for help
with processing T&A’s through STAR.

The help feature is available to guide you as you process data in STAR. To get help, select
Help  from the menu bar at any window. A drop-down menu is displayed with the following
options:

• Help For This Window. Provides instructions for the current window.

• Help Contents. Provides extensive field-level help for STAR.

• Help for Help. Provides instructions for using help.

For help with a specific field, click the field in question and press [F1].

Starting STAR

Before STAR can be installed, the System Administrator must set up STAR users through
EMCP and assign user permissions through PRMS. Instructions for setting up users can be
found in the PRMS procedure. PRMS is available on the Internet through the NFC
Download Center, by FTP download, on CD-ROM, or 3 1/2-inch diskette. The EMCP
application has been combined with the PRMS application and is issued as one download
file, one CD-ROM, or set of diskettes. Therefore, when the System Administrator installs
PRMS, EMCP is installed as well. A tutorial and Readme file are also available.

Instructions for installing STAR (and other NFC applications) are provided in the NFC
Resource Center on the NFC home page at www.nfc.usda.gov. If you encounter problems
after installation, see the Readme file and/or contact your Information Technology Office or
NFC’s Customer Support personnel at 504-255-5230.

Note:  If when trying to install STAR, you get an Open Data Base Connect (ODBC) error
message, you must first make sure that you are running version 3.0 or greater of ODBC. If
you do not have 3.0 or greater, you must reinstall your mdac file. Windows 95 and 98 users
should also reinstall the applicable dcom file.



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

8 Updated 9/12/03

For more information, see:

Reporting

Arranging And Viewing Multiple Windows

Reporting

The following reports should be used to ensure that T&A’s have been received by NFC. For
detailed instructions on how to run these or any other CULPRPT reports, see Title I,
Chapter 20, Section 1, Payroll/Personnel Report Generator System (CULPRPT).

• Confirmation Report.  Review this report to ensure that all T&A’s were successfully
transmitted. After the transmission of T&A’s, this report is generated to the destination
identified on JCL.

• CULPRPT Report P0013, Active Full/Part-Time Employees-T&A’s Not Received
By NFC. Review this report to verify that there are no outstanding T&A’s to be
transmitted. This report is updated after each pass of TIME. Agency staff responsible
for monitoring T&A’s should run the report after each pass on Thursday and Friday of
PAYE week.

• CULPRPT Report P0099, Error Analysis For T&A Processing. Review this report
to determine if there are any T&A’s that are in suspense because a payroll document or
a personnel action has not been processed. This report is available beginning the first
Monday of the pay period and should be run every day after T&A’s are transmitted.

Arranging And Viewing Multiple Windows

The Window option appears on STAR menu bars, allowing the arrangement of open
windows for simultaneous display. To use this feature, select Window  from any menu bar.
The Window pull-down menu (Figure 1 ) is displayed showing the available option.

Figure 1. Window Pull-down Menu

Below is a brief description of that option:

• Cascade . Overlaps the windows so that each title bar is visible.

System Access

This section provides specific log-on/log-off instructions.

For more information, see:

Logging On

Exiting STAR

Logging On

The Logon pop-up (Figure 2 ) is used to log on to STAR.
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To log on to STAR after STAR is installed on your PC:

1. Click the STAR icon located on your desktop. IF the icon is unavailable, from the
Start menu, select Start > Programs > National Finance Center > Star . The Logon
pop-up (Figure 2 ) appears.

Figure 2. Logon pop-up

2. Complete the User ID field as indicated under Logon Pop-up Field Instructions .

3. Click [Logon] . You are connected to STAR.

Exiting STAR

To exit STAR, select File > Exit  on the STAR Menu Bar. To exit the current window, 

click .

STAR Operating Features

STAR is designed in a Windows format, providing mouse-driven, point-and-click
functionality; command buttons; and other Windows features. This section reviews these
basic Windows features and describes other features that are specific to the STAR
application.

Note:  For ease of use, users may tab through various fields and buttons instead of clicking
the mouse if he/she so chooses.

Note:  Window  and Help  appear on all menu bars and display the same pull-down menus.
Instructions for using Window  are provided under Arranging And Viewing Multiple Windows .
Instructions for using Help  are provided under STAR Help .

For more information, see:

STAR Tool Bar

STAR Command Buttons

STAR Pop-ups

STAR Functional/Directional Keys

STAR Message Pop-ups

STAR Radio Buttons

Clearing STAR Fields

Deleting Items In STAR
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STAR Tool Bar

The STAR tool bar is a row of tool (icon) buttons located below the menu bar. Each tool
button displays an icon that depicts its processing function. Tool buttons, like menu options,
are used to display windows and initiate functions that are relevant to the open window. In
fact, tool buttons are shortcuts for selecting options from the pull-down menus. In most
cases, the tool buttons can be used in lieu of the menu bar.

Tool buttons used throughout STAR are shown in the following table:

STAR Tool Buttons

Button Description

Used to add a record.

Used to display employee’s biweekly T&A.

Used to navigate users on the Biweekly T&A window.

Used to close a window.

Used to convert data from PC-TARE to STAR.

Used to create a new folder.

Used to delete a record.

Used to display the folders in a detailed format.

Used to display the employee detail record.

Used to display the employee list.

Used to display the employee print list.

Used to display the employee transmit list.

Used to export table data.

Used to display help text.

Used to import table data.

Used to display the leave account.
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STAR Tool Buttons

DescriptionButton
Used to display the folders in a list format.

NAME

Used to advance to the next employee record when sorting
by name.

SSN

Used to advance to the next employee record when sorting
by SSN.

NAME

Used to return to the previous employee record when sorting
by name.

SSN

Used to return to the previous employee record when sorting
by SSN.

Used to open a pop-up from an open window.

Used to print a screen or T&A records.

Used to roll over data.

Used to save a record.

Used to search for a record.

Used to select a record.

Used to display the employee’s T&A header record.

Used to display the T&A list.

Used to update an employee record.

Used to move up one level.

Used to display user permissions.

Used to verify a T&A.

STAR Command Buttons

STAR pop-ups include command buttons that carry out an action described in the button’s
name. STAR includes the following command buttons:
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STAR Command Buttons

Button Description

Add
Used to add a record.

Add New
Used to add a new T&A.

Build
Used to build JCL.

Cancel
Used to cancel a function.

Change
Used to change a T&A record.

Clear
Used to clear the detail area to add a record.

Continue
Used to continue.

Correct T&A
Used to prepare a corrected T&A.

Delete
Used to delete a record.

Deselect All
Used to deselect all records for backup/restore.

Find
Used to search for a record.

Logon
Used to log on to STAR.

Merge
Used to merge a split T&A.

OK
Used to advance to the next window and/or acknowledge the
message.

Open
Used to select an import file or save a transmit file.

Proceed
Used to proceed with the backup process.

Proceed With
Backup

Used to proceed to the Backup pop-up.

Proceed With
Restore

Used to proceed to the Restore pop-up.

Remove
Used to remove one selected item.

Print All
Used to print all T&A’s.
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STAR Command Buttons

DescriptionButton

Print Selected
Used to print only those T&A’s selected.

Select All
Used to select all items.

Split Selected T_A
Used to split the selected T&A.

Scroll
Used to continue to scroll on a table.

Update
Used to update a record.

Xmit All
Used to transmit all T&A’s.

Xmit Selected
Used to transmit only those T&A’s selected.

STAR Pop-ups

Pop-ups do not have a menu bar or a tool bar; however, they do have command buttons that
carry out an action implied in the button’s name. STAR pop-ups include the following
command buttons used throughout STAR:

STAR Pop-ups

Button Description

Cancel
Used to cancel a function.

Continue
Used to continue a process.

Delete
Used to delete a record.

Find
Used to search for the data entered.

No Used to answer the displayed message.

OK
Used to acknowledge the displayed message.

Open Used to select an import file or save a transmit file.

Yes
Used to answer the displayed message.
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STAR Functional/Directional Keys

Your keyboard includes the following function keys to be used in STAR:

Function Keys

Key Description

PF1
Used to display Help.

PF2
Used to search for the data entered.

PF3
Used to close the active window.

PF4
Used to add a record.

PF5
Used to update a record.

PF6
Used to delete a record.

Alt
Used in conjunction with the Hot Keys (underlined
characters) to perform certain actions.

Ctrl
Used in conjunction with the P key to print records.

Tab
Used to advance to the next field.

STAR Message Pop-ups

Throughout STAR, message pop-ups appear when certain actions are performed. These
pop-ups notify the user of an action that must be taken and/or an error condition that must be
corrected. Command buttons are used on these pop-ups. These command buttons accept or
cancel the message. You must click a command button in order for the pop-up to disappear
and to be returned to the active window. Following is an example of a message
pop-up (Figure 3 ).

Figure 3. Message pop-up
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STAR Radio Buttons

Round buttons called radio buttons are used throughout STAR. Radio buttons are used to
select the data that will be placed in a field; select options such as a function, navigation
path, or data category; and specify selection criteria, such as a data category, for a particular
search.

Clearing STAR Fields

Before a record can be added in STAR, the key fields must be blank. If the fields contain
data, you must click [Clear]  before entering data into STAR fields. After entering the data
into the fields, the [Add]  option then becomes available.

Deleting Items In STAR

Throughout STAR, the same process is used to delete records.

To delete a record in STAR:

1. At the applicable selection window, select the record to be deleted and click [Delete] .
A Confirm Delete pop-up (Figure 4 ) appears.

Figure 4. Confirm Delete pop-up

2. Click [Delete]  to delete the applicable record or [Cancel]  to cancel the action and
return to the previous window.

STAR Menu Bar

After accessing STAR, the STAR Menu Bar (Figure 5 ) is displayed showing the STAR Menu
Bar with five options.
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Figure 5. STAR Menu window

Below is a brief description of each option.

• File . Used to display employee maintenance windows for T&A preparation, T&A
maintenance windows for T&A preparation, prepare T&A transmission files, print
T&A’s, and exit STAR.

• System . Used to set up and maintain authorized users, convert data from PC-TARE to
STAR data, back up and restore data, archive data, import data into tables, export table
data to other PC’s, establish and maintain contact point information, build and
maintain JCL files, and identify the default auto back up directory.

• Tables . Used to view, update, or print data from the accounting, transaction, pay
period and leave tables maintained in STAR.

• Window . Used to cascade open windows.

• Help . Used to display help.

To display help for an option, move to the option and select Menu Option > Help  at any
window. The field-level help (Figure 6 ) is displayed. To return to the previous STAR

window, click at any window.
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Figure 6. STAR Help

Each option on the STAR Menu Bar has a coordinating drop-down menu with additional
options. To select an option from the STAR Menu Bar, position the arrow at the applicable
selection and click the selection.

Instructions follow for selecting and using the application options.



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

18 Updated 9/12/03



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

P
art N

O
 TA

G
S

ystem
 M

aintenance

19Updated 9/12/03

System Maintenance

This section presents the following topics:

Contact Points

JCL

Defining Authorized Users

Data Conversion

Backup/Restore

Automatic Backup

Import/Export

Archive

Contact Points

The T&A Contact Point is used by NFC to identify each location that transmits T&A’s and to
identify inquiries concerning transmitted T&A’s. Also, the contact point appears in the
heading of printouts produced by NFC and all T&A’s transmitted to NFC. The contact point
consists of the agency, state code, town code, unit code, and the timekeeper number.

The Contact Point Maintenance option is used by the Application Administrator to add,
modify, or delete STAR contact point records. Once the Application Administrator adds these
contact point records, the User Administrator can assign records to STAR users. Records are
assigned in the Authorized Users/User Permissions option. To get to the Contact Point
Maintenance window, select System > Contact Point  from the STAR Menu Bar. The Contact
Point Maintenance window (Figure 7 ) is displayed with the available options highlighted.

Before a contact point record can be deleted, the User Administrator must remove the contact
point from the user in the User Permissions option. Once this is done, the Application
Administrator can delete a contact point record. For instructions on deleting a contact point
record, see Deleting Items In STAR .

Note:  You cannot delete a contact point that has employees with active records. User must
archive the employee T&A data and delete all employees before the contact point can be
deleted.
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Figure 7. Contact Point Maintenance window

Note:  Contact points established in STAR must also be established in TMGT, Table 003,
T&A Contact Point Name And Address.

For more information, see:

Adding Or Updating A Contact Point Record

Searching For A Contact Point Record

Adding Or Updating A Contact Point Record

The Application Administrator uses this option to add or update a contact point record from
the Contact Point Maintenance window (Figure 7 ).

To add or update a contact point record:

1. Select System > Contact Point  from the STAR Menu Bar. The Contact Point
Maintenance window is displayed with the available options highlighted.

2. Complete the fields as indicated under Contact Point Maintenance Window Field
Instructions .

3. After completing the fields in the detail area group box, click [Add]  to add the contact
point record.

4. To update a contact point record, select the applicable contact point record in the list
box or use the scroll bar to select a contact point record. The contact point selected
will display in the detail area.

5. Complete the fields to be changed.

6. After modifying the information, click [Update] .
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Searching For A Contact Point Record

The Contact Point Search pop-up (Figure 8 ) is used by the Application Administrator to
search for a contact point record.

To search for a contact point record:

1. Select System > Contact Point  from the STAR Menu Bar. The Contact Point
Maintenance window (Figure 7 ) is displayed.

2. Click . The Contact Point Record Search pop-up (Figure 8 ) appears.

Figure 8. Contact Point Record Search pop-up

3. Complete the fields as indicated under Contact Point Search Pop-up Field
Instructions .

4. Either click [Find]  to search for a contact point record, or [Cancel]  to cancel the search.

JCL

The JCL option is used by the Transmitter to establish or change the JCL. The JCL must
reflect your agency’s specifications to transmit files before data can be transmitted to NFC. If
you do not want to use the JCL, you must deselect the Use JCL box on the Prepare Transmit
File window (Figure 52 ). For more information on the Use JCL box, see Transmitting T&A’s .

For more information, see:

Building JCL

Building JCL

This option allows the Transmitter to build JCL. The JCL that is built is displayed in the Job
Control Language box at the bottom of the window.

To build JCL:

1. Select System > JCL  from the STAR Menu Bar. The Build JCL window (Figure 9 ) is
displayed.
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Figure 9. Build JCL window

2. Complete the fields as indicated under Build JCL Window Field Instructions .

3. Click  to save JCL when there is more information to be added or [Build]  to build
JCL. 

The JCL is established and appears in the bottom portion of the window. If further
updates are needed after JCL is established, you must make the applicable changes and

click  to change the JCL.

Defining Authorized Users

The Authorized Users option is used by the User Administrator to designate contact point
locations to specific STAR users from the authorized user list. The contact point numbers are
established in the Contact Point option by the Application Administrator. The STAR user is
responsible for all employees for this contact point. This option is seen by the User
Administrator only. To get to the Authorized Users List window, select System > Authorized
Users  from the STAR Menu Bar. The Authorized User List window (Figure 10 ) displays a
list of authorized STAR users set up in PRMS.
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Figure 10. Authorized User List window

To display established contact points for a particular user, select the desired user from the

Authorized User List window and click . The User Permissions window (Figure 11 ) is
displayed.

Note:  Double clicking on any user will automatically active the User Permission window.

Figure 11. User Permissions window

The User Permissions window displays a list of available or selected contact points for a
specific user.
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For more information, see:

Adding/Removing Contact Point(s) On The Selected List

Searching For An Authorized User

Adding/Removing A Contact Point(s) On The Selected List

The User Administrator can change the contact point(s) assigned to a Timekeeper to either
the selected list from the available list or back to the available list from the selected list.

Note:  To delete a record from the Available list, you must use the Contact Point option. For
more information on using the Contact Point option, see Contact Points , and for more
information on deleting records, see Deleting Items In STAR .

To add/remove a contact point:

1. Select System > Authorized User  from the STAR Menu Bar. The Authorized User List
window (Figure 10 ) is displayed. For more information on the Authorized User List
window, see Authorized User List Window Field Instructions .

2. Select the applicable user on the Authorized User List and click . The User
Permissions window (Figure 11 ) is displayed with lists of available and selected
contact points. For more information on the User Permissions window, see User
Permissions Window Field Instructions .

3. To add a contact point to the selected list, at the User Permissions window select the
applicable contact point and click [Add] .

4. To remove a contact point from the selected list and return it to the available list, select
the applicable contact point and click [Remove]

Note:  Double clicking a contact point record moves it from one category to the other.

Searching For An Authorized User

This option allows the User Administrator to search for an authorized user.

To search for an authorized user:

1. Select System > Authorized User  from the STAR Menu Bar. The Authorized User List
window (Figure 10 ) is displayed.

2. Click . The Authorized User Search pop-up (Figure 12 ) appears.

Figure 12. Authorized User Search pop-up
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3. Complete the User ID field as indicated under Authorized User Search Pop-up Field
Instructions .

4. Click [Find]  to search for a user on the Authorized Search pop-up or [Cancel]  to cancel
the search.

Data Conversion

The Data Conversion option is used by the Timekeeper to convert data from PC-TARE into
STAR. Data from any version of PC-TARE may be converted. Employee list data, T&A
data, and header data are converted by using the data conversion option. To convert data,
select System > Data Conversion  from the STAR Menu Bar. The Data Conversion
window (Figure 13 ) is displayed.

Figure 13. Data Conversion window

For more information, see:

Converting Data

Converting Data

The timekeeper uses the Data Conversion window to convert PC-TARE data to STAR data.
This is done before the user begins processing T&A’s in STAR.

To convert PC-TARE data to STAR data:

1. Select System > Data Conversion  from the STAR Menu Bar. The Data Conversion
window (Figure 13 ) is displayed.
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2. Select the appropriate conversion type and the pay period of the data to be converted.

3. Complete the fields as indicated under Data Conversion Window Field Instructions .

4. Click  to convert the data.

Note:  If any errors arise during the conversion process, correct these errors in STAR.

5. Select the location of the file to be converted.

6. Click  and click [OK]  on the Conversion Status Pop-up.

7. Select [OK]  on the Conversion Status pop-up.

Backup/Restore

The backup and restore features of STAR are used by the System Administrator or
Timekeeper to back up T&A and table data and to restore data. To back up or restore data,
select System > Backup/Restore  on the STAR Menu Bar. The Contact Point List For
Backup/Restore Processing pop-up (Figure 14 ) appears with a list of all contact points for
that timekeeper. For more information on the Contact Point For Backup/Restore Processing
pop-up, see Contact Point List For Backup/Restore Processing Pop-up Field Instructions .

Figure 14. Contact Point List For Backup/Restore Processing pop-up

For more information, see:

Backing Up Data

Restoring Data

Backing Up Data

Backup is used to back up T&A data to avoid the accidental loss of data. T&A data should
be backed up once a pay period. Data that is backed up can be restored to any PC or LAN
drive. Backup may be saved to any drive. The backup path must be defined before data can
be backed up. For instructions on the Backup Path pop-up, see Backup Path Pop-up Field
Instructions .
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The System Administrator defines the path where the backed up data is to be stored.

To back up data:

1. On the Contact Point List For Backup/Restore Processing pop-up (Figure 14 ),
click [Proceed With Backup] . The Backup Path pop-up (Figure 15 ) appears.

Figure 15. Backup Path pop-up

2. Complete the Path field as indicated under Backup Path Pop-up Field Instructions .

3. Click [OK]  to back up the data or [Cancel]  to cancel the backup and return to the
Contact Point List For Backup/Restore Processing pop-up. If you click [OK] , the
Backup pop-up (Figure 16 ) appears.

Figure 16. Backup pop-up

4. Complete the fields as indicated under Backup Pop-up Field Instructions .

5. Click [Proceed]  to proceed with the backup process or [Cancel]  to cancel the backup.
A message, Backup was successful, is displayed after the backup process is
performed.

Note:  If you use the same path each pay period, the previous pay period data is
replaced with the current pay period data.

Restoring Data

Restore is used to (1) retrieve data that was accidentally deleted or move an employee record
from one PC to another and to restore T&A’s that have been archived.
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The System Administrator or Timekeeper uses this option to restore data.

To restore T&A data:

1. On the Contact Point List For Backup/Restore Processing pop-up, click [Proceed With
Restore] . The Restore pop-up (Figure 17 ) appears.

Figure 17. Restore pop-up

2. Complete the fields as indicated under Restore Pop-up Field Instructions .

3. After completing the fields, click [Continue]  to continue with the restore process
or [Cancel]  to cancel the function. If you click [Continue] , an Open pop-up (Figure 18 )
appears.

Figure 18. Open pop-up

4. Complete the fields as indicated under Open Pop-up For Restore Field Instructions .
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Note:  The following backed-up files are used when restoring data:

• ACCTGXXXXXXXX (to be used when restoring the Accounting Table)

• CNTPTXXXXXXXX (to be used when restoring the Contact Point Table)

• LEAVEXXXXXXXX (to be used when restoring the Leave Type Table)

• PPXXXXXXXX.bak (to be used when restoring the Pay Period Table)

• STAR_DEFXXXXXX (to be used when restoring STAR default data)

• STAR_TAXXXXXX (to be used when restoring T&A data)

• TCXXXXXXXX.bak (to be used when restoring the Transaction Code Table)

Note:  The last 8 digits in the file name are the date the file was created. The first 4
indicate the year, the second 2 indicate the month, and the last 2 indicate the day of the
month. For example, ACCTG20000103 refers to 2000, January 03.

5. Click [Open]  to restore the file(s) or [Cancel]  to cancel the restore. You are returned to
the Restore pop-up (Figure 17 ) for either option chosen.

Automatic Backup

STAR allows any user to select a backup directory. The auto backup directory option does an
automatic backup of the database file.

To perform automatic backup:

Note:  The backup directory option is user ID specific and not workstation specific. For
example, user NFCxxb serves as a backup when user NFCxx is out. Both users have
identical access and share the same workstation or LAN directory for STAR purposes.
Both users must establish a backup path while logged into their respective ID’s. This
path does not automatically apply to user NFCxxb even though the user have identical
paths.

1. Select System > Auto Backup Directory  from the STAR Menu Bar. The Automatic
Backup Directory pop-up (Figure 19 ) appears.

Note:  It is recommended that a user does not use the same backup directory and/or
name as another user so that they do not overwrite each others’ files if using individual
databases.

Figure 19. Automatic Backup Directory pop-up
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2. On the Automatic Backup Directory pop-up, complete the Specify Path For Automatic
Backup field as indicated under Automatic Backup Directory Pop-up Field
Instructions .

3. Click [OK]  to define the backup drive or [Cancel]  to cancel the function and return to
the STAR Menu Bar.

Note:  You only have to complete this process once. After this process is initially
completed, the database is automatically backed up to the specified directory each time
the user exits STAR.

Import/Export

Export is used to transfer data from tables in one STAR database to another STAR database.
The Import option is used by the System Administrator to import accounting, leave, pay
period, and TC tables into the STAR database. Before data can be imported, data must be
exported onto a disk making the data available for import.

For more information, see:

Exporting A File

Importing A File

Exporting A File

The System Administrator can export table data onto a specific drive or any LAN drive.

To export a file:

1. Select System > Import/Export  from the STAR Menu Bar. The Import/Export 
window (Figure 20 ) is displayed.

Figure 20. Import/Export window
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2. Select the table to be exported and click . The Export Path/File Name 
pop-up (Figure 21 ) appears.

Figure 21. Export Path/File Name pop-up

3. Complete the Path and File Name field as indicated under Export Path/File Name
Pop-up Field Instructions .

4. Click [OK]  to export the file or [Cancel]  to cancel the function. The message,
Processing Was Successful is displayed on the Import/Export window after you
export the file.

Note:  Prior to using the Export function, back up your STAR files to avoid accidental
loss of files.

Importing A File

The System Administrator can import table data to multiple PC’s or LAN’s. This
customization of STAR PC’s saves time and minimizes errors because each timekeeper does
not have to enter his/her own table data.

To import a file:

1. Select System > Import/Export  from the STAR Menu Bar. The Import/Export 
window (Figure 20 ) is displayed.

2. Select the table to be imported.

3. Click  on the Import/Export window (Figure 20 ). The Open pop-up (Figure 18 )
appears.

4. In the Look In box, click ][  to locate the applicable drive of the file you are
importing.

5. Click the applicable drive so that the drive is displayed in the Look In box.

6. Complete the fields as indicated under Open Pop-up For Import Field Instructions .

7. Click [Open]  to import the text file or [Cancel]  to cancel the import. The message
Processing Was Successful is displayed on the Import/Export window after you
import the file.
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Archive

Archive is used by the System Administrator or Timekeeper to remove older T&A’s from the
database. Archived data can always be restored by using the Restore option. Data is archived
for a contact point by pay period and year. Data can be archived to an applicable drive or any
LAN drive. The archive function may also be used to retire the T&A records of a separated
employee so that he/she may be deleted from the main database.

For more information, see:

Archiving Data

Archiving Data

The System Administrator or Timekeeper uses the Archive option. The Contact Point List
defines which contact point T&A’s are to be archived. Archived data can always be restored.

To archive data:

1. Select System > Archive  from the STAR Menu Bar. �The Archive pop-up (Figure 22 )
appears.

Figure 22. Archive pop-up �

2. Complete the fields as indicated under Archive Pop-up Field Instructions .

3. Click  to select the pay period, the Archive Pay Period List pop-up (Figure 23 )
appears. Select the applicable pay period and click [Select]  to select the pay period
or [Cancel]  to cancel the function. After clicking [Select]  or [Cancel] , you are returned
to the Archive pop-up (Figure 22 ).

4. To archive a single employee, key in the applicable SSN and click [Continue].
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Figure 23. Archive Pay Period List pop-up

5. Click [Continue]  to archive the data or [Cancel]  to cancel the archive and return to the
STAR Menu Bar. If you click [Continue] , the Archive Path pop-up (Figure 24 )
appears.

Figure 24. Archive Path pop-up

To define the archive path:

1. On the Archive pop-up (Figure 22 ), click [Continue] . The Archive Path
pop-up (Figure 24 ) appears.

2. Complete the Path And File Name field as indicated under Archive Path Pop-up Field
Instructions .

Note:  When performing subsequent archives, make sure the path and file name are
different from previous archived files; otherwise, the file(s) will be overwritten.

3. Click [Continue]  to define the path or [Cancel]  to cancel the function. After
clicking [Continue]  or [Cancel] , you are returned to the Archive pop-up.
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Tables

This section presents the following topics:

About Tables

Accounting Code

Transaction Code

Pay Period

Leave Type

About Tables

Tables is an option on the STAR Menu Bar. The Tables menu is displayed when you select
Tables  from the STAR Menu Bar. This option is used by the Application Administrator to
maintain the STAR accounting, transaction code (TC), pay period, and leave type tables.
Also, the timekeeper can modify the accounting and pay period tables.

Accounting Code

Accounting Code is an option on the Tables menu. The Accounting Code table is used to
enter, edit, and delete accounting codes used on the T&A. For information on deleting an
accounting code, see Deleting Items In STAR . The Accounting Code table installed with
STAR contains no data. In addition, as long as the Accounting Code Table is blank, STAR
will accept any accounting codes entered on the T&A. However, once the Accounting Code
Table contains data, only codes in the table are acceptable. This section provides instructions
for completing the accounting data recorded on the T&A.

Each employee’s record maintained at NFC contains appropriation and accounting
information that is used to disburse and charge the employee’s pay and related expenditures
to the proper accounting records. Each agency uses unique accounting codes and formats.
The accounting data entered on the T&A is edited for validity and field length.

The Accounting Code table can be customized by adding your agency’s valid accounting
codes. The format of accounting codes on the table must agree with the accounting code
entered on the T&A.

To get to the Accounting Code List window, select Tables > Accounting Code  from the
Tables menu. The Accounting Code List window (Figure 25 ) is displayed.
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Figure 25. Accounting Code List window

For more information, see:

Adding Or Updating An Accounting Code

Searching For An Accounting Code

Rolling Over An Accounting Code

Adding Or Updating An Accounting Code

The Application Administrator and/or Timekeeper can add an accounting code to the
Accounting Code Table or update an accounting code that is already established on the
Accounting Code Table.

To add or update an accounting code:

1. Select Tables > Accounting Code  from the STAR Menu Bar. The Accounting Code
List window (Figure 25 ) is displayed with the available options highlighted.

2. To add an accounting code, complete the fields as indicated under Accounting Code
List Window Field Instructions .

3. After entering data into the key field, the Add option becomes available. Click [Add]
to add a new accounting code.

OR

To update an accounting code, select the applicable accounting code. The accounting
code selected will display in the detail area.

4. Make the applicable changes.

5. After modifying the information, click [Update]  to update the accounting code.
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Note:  Only the description field may be modified. To make changes to the category
field, the accounting code must be deleted and reentered. For information on deleting
an accounting code, see Deleting Items In STAR .

Searching For An Accounting Code

This option is used to search for an accounting code.

To search for an accounting code:

1. Click  on the Accounting Code List window (Figure 25 ). The Accounting Code
Search pop-up (Figure 26 ) appears.

Figure 26. Accouting Code Search pop-up

2. Complete the fields as indicated under Accounting Code Search Pop-up Field
Instructions .

3. Click [Find]  to search for an accounting code on the Accounting Code List window
or [Cancel]  to cancel the search.

Rolling Over An Accounting Code

The Application Administrator and/or Timekeeper can use this option to roll over accounting
codes from the current fiscal year to the new fiscal year. This option provides for updating
the Accounting Code table to include codes for the next fiscal year. This feature allows
STAR to maintain more than one set of accounting codes.

By using the rollover option, a new list of accounting codes is developed. The current fiscal
year accounting codes are still present on the Accounting Code table. The current fiscal year
accounting codes must be deleted to be removed from the Accounting Code table.

Prior and current fiscal year accounting codes should be maintained to allow the entry of a
corrected T&A.

To roll over an accounting code:

1. Select Tables > Accounting Code  from the STAR Menu Bar. The Accounting Code
List window is displayed.

2. On the Accounting Code List window, select Edit > Rollover Accounting . The
Accounting Code Rollover pop-up (Figure 27 ) appears.
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Figure 27. Accounting Code Rollover Pop-up

3. Complete the fields as indicated under Accounting Code Rollover Pop-up Field
Instructions  to roll over the accounting codes from the current fiscal year to the new
fiscal year,.

4. After completing the fields, click [Create New Acctg Codes]  to roll over the
accounting codes or [Cancel]  to cancel the function. The Accounting Code Rollover
pop-up (Figure 27 ) closes after you click [Create New Acctg Codes]  or [Cancel] . You
are returned to the Accounting Code List window (Figure 25 ).

Note:  After clicking [Create New Acctg Codes]  on the Accounting Code Rollover 
pop-up (Figure 27 ), you must close the Accounting Code List window to refresh the
window. The next time you open the Accounting Code List window you can view the
new accounting code.

Transaction Code

The Transaction Code (Figure 28 ) table contains a list of TC’s from which each T&A
prepared is edited against. The Transaction Code table that is built into STAR during
installation contains a list of all TC’s available for T&A processing. These TC’s are taken
from Table Management System (TMGT) Table 032, Transaction Codes. The Application
Administrator can enable or disable those TC’s applicable to your agency. Timekeepers will
see only those TC’s that are selected as enabled. In the event that new TC’s are implemented,
the Application Administrator will receive instructions for adding the new TC to the table.

Note:  You cannot delete a TC from the table. TC’s can only be enabled or disabled. You can
use the Enable field to customize your TC table so that Timekeepers will only see those TC’s
applicable to the agency.

This group of fields contains 3 parts: the prefix, the TC, and the suffix.

The transaction prefix is a code used to expand the definition for certain TC’s or to create a
new TC and definition when the TC has been previously used without a prefix.
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The TC is used to record hours worked, absences, allowances/differential entitlements, and
other entitlements. Each TC symbolizes a specific rate and kind of pay or absence.

The transaction suffix can be used with a variety of TC’s. However, its use is required for
wage grade employees to designate the shift for the TC entered.

Figure 28. Transaction Code List window

For more information, see:

Searching For A Transaction Code

Adding Or Updating A Transaction Code

Enabling Or Disabling A Transaction Code

Searching For A Transaction Code

This option allows you to search for a TC on the Transaction Code table.

To search for a TC:

1. Select Tables > Transaction Code  from the STAR Menu Bar. The Transaction Code
List window (Figure 28 ) is displayed.

2. Click  on the Transaction Code List window. The Transaction Code Search 
pop-up (Figure 29 ) appears.
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Figure 29. Transaction Code Search pop-up

3. Complete the TC field as indicated under Transaction Code Search Pop-up Field
Instructions .

4. Click [Find]  to search for a TC or [Cancel]  to cancel the search.

Adding Or Updating A Transaction Code

The Application Administrator can add a new TC in the event that a new TC is established or
can update a TC that has already been established on the Transaction Code table.

To add a new TC or modify a TC that has already been established on the TC table:

1. Select Tables > Transaction Code  from the STAR Menu Bar. The Transaction Code
List window (Figure 28 ) is displayed with the available options highlighted.

2. To add a new TC, complete the fields as indicated under Transaction Code List
Window Field Instructions .

OR

To modify a TC that has already been established, select the applicable TC. The TC
selected will display in the detail area.

3. Make the applicable changes.

4. After adding/modifying the information, click [Add]  to add a TC, or [Update]  to
modify an existing TC.

Enabling Or Disabling A Transaction Code

This option is used by the Application Administrator to enable or disable TC’s. This allows
the agency timekeepers to only see those TC’s that are applicable to that agency when
entering T&A’s on the Biweekly T&A window (Figure 41 ) and using the Transaction Code
Selection pop-up (Figure 43 ) to select TC’s. All TC’s are marked as enabled (Y) when the
Application Administrator initially works with the table.

To enable/disable a TC:

1. Select Tables > Transaction Code  from the STAR Menu Bar. The Transaction Code
List window (Figure 28 ) is displayed.



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

P
art N

O
 TA

G
Tables

41Updated 9/12/03

2. Select the TC to be enabled/disabled.

3. Make the applicable change in the Enable field.

4. Click [Update] . The Enable field now displays an N to represent the change.

Pay Period

Pay Period is an option on the Tables menu. This option initially displays pay period
numbers and dates for 26 previous, 26 current, and 26 future pay periods from the date of
STAR implementation. To get to the Pay Period List window, select Tables > Pay Period
from the Tables menu. The Pay Period List window (Figure 30 ) is displayed. For instructions
on using the Pay Period List window, see Pay Period List Window Field Instructions .

Figure 30. Pay Period List window

Note:  To create additional pay periods, select Edit > Generate Pay Periods . The previous
year’s pay periods, the current year’s pay periods, and the next year’s pay periods are
displayed.

Leave Type

Leave Type is an option on the Tables menu. This option displays the various leave types
used by employees. When a new leave type is added to the Payroll/Personnel System, the
Application Administrator will receive instructions for adding the new leave type to the
table. A new leave type can only be added after the corresponding TC has been established
on the TC table. Only leave types added by an agency may be updated or deleted. For more
information on deleting a leave type, see Deleting Items STAR Records .
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For more information, see:

Searching For A Leave Type On The Table

Adding A Leave Type To The Leave Type Table

Searching For A Leave Type On The Table

You can search for a leave type on the Leave Type Table.

To search for a leave type:

1. Select Tables > Leave Type  from the STAR Menu Bar. The Leave Type List 
window (Figure 31 ) is displayed with the available options highlighted.

Figure 31. Leave Type List window

2. Click . The Leave Type List Search pop-up (Figure 32 ) appears.

Figure 32. Leave Type Search pop-up

3. Complete the fields as indicated under Leave Type Search Pop-up Field Instructions .
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4. Either click [Find]  to search for a leave type or click [Cancel]  to cancel the search.
After clicking [Find]  or [Cancel] , you are returned to the Leave Type List window.

Adding A Leave Type To The Leave Type Table

The Application Administrator can add a new leave type on the Leave Type Table. Leave
types can only be added when a new leave TC is added to the Payroll/Personnel System.

To add a leave type on the Leave Type Table:

1. Select Tables > Transaction Code  from the STAR Menu Bar. The Transaction Code
List window (Figure 28 ) is displayed. For information on using the Transaction Code
List window, see Adding Or Updating A Transaction Code .

2. Click . The Leave Type List window (Figure 31 ) is displayed.

3. To add a new leave type, complete the fields as indicated under Leave Type List
Window Field Instructions .

4. After adding the information, click [Add]  to add a new leave type.

Note:  Only leave types added by the Application Administrator when a new TC is
added to the Payroll/Personnel System may be updated or deleted. Leave types
contained in the STAR application may not be updated or deleted.
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Employee Maintenance

This section presents the following topics:

About Employee Maintenance

Searching For An Employee Record

Adding Or Updating An Employee Leave Account

Maintaining Leave Accounts

Printing The Open Window

About Employee Maintenance

The Employee Maintenance option is used by Timekeepers to record employee data. When a
Timekeeper has access to more than one contact point, the Contact Point List
window (Figure 33 ) is displayed before the Employee List window (see Figure 34 ). You must

select the applicable contact point record and click  before the Employee List window is
displayed.

Figure 33. Contact Point List window

Select File > Employee Maintenance  from the STAR Menu Bar. The Employee List
window (Figure 34 ) is displayed with the available options highlighted. The Employee List
window displays a list of all employees for the selected contact point that are maintained by a
Timekeeper. You can sort the Employee List by either name or SSN. The window defaults to
SSN, but you can select View > Sort By Name  to change the sort feature.
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Figure 34. Employee List window

Searching For An Employee Record

This option allows you to search for an employee record on the Employee List
window (Figure 34 ).

To search for an employee record:

1. On the Employee List window, click . The Employee Search pop-up (Figure 35 )
appears.

Figure 35. Employee Search pop-up

2. Complete the fields as indicated under Employee Search Pop-up Field Instructions .

3. Either click [Find]  to search for an employee record or [Cancel]  to cancel the search.
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Adding Or Updating An Employee Record

This option allows the Timekeeper to add a new employee record, modify an existing
employee record, or delete an employee record. Before an employee record can be deleted or
archived, all T&A records for the employee must be deleted or archived. T&A’s that have not
been transmitted may be deleted; however, T&A’s that have already been transmitted must be
archived. If the employee has any active T&A’s, the employee record cannot be deleted. For
more information on deleting an employee, see Deleting Items In STAR .

Note:  If a T&A Contact Point has changed as a result of a reorganization, move, etc., the
change must be made in EMCP. In this event, the Timekeeper should contact the agency
designated representative to make the change.

To add/update an employee:

1. On the Employee List window (Figure 34 ), click  to add a new employee record.
The Employee window (Figure 36 ) is displayed.

OR

Select the applicable employee record and click . The Employee window is
displayed.

Note:  Although the Employee window is accessed through the Employee List in
STAR, the Employee window is the same window used by EMCP; therefore, when a
customer enters data on the Employee window, the customer is actually entering data
in EMCP.

Figure 36. Employee window

2. Complete the fields as indicated under Employee Window Field Instructions .

Note:  The Contact Point field defaults to the contact point the Timekeeper is currently
working in and has access to.

3. Click  on the Employee window (Figure 36 ) to save the record. The message The
Save Was Successfully Performed is displayed.
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4. Click  to return to the Employee List window (Figure 34 ).

Note:  If this is the first pay period for an employee, a New Employee Pay Period
Selection List pop-up (Figure 37 ) appears. Select the employee’s first pay period on
the New Employee Pay Period Selection List pop-up and click [OK] . After clicking
[OK]  on the New Employee Pay Period Selection List pop-up, the Employee Leave
Account window (Figure 38 ) is displayed. For information on the Employee Leave
Account window, see Adding Or Updating An Employee Leave Account Record .

Figure 37. New Employee Pay Period Selection List pop-up

Maintaining Leave Accounts

The Leave Account option is used to maintain the leave accounts for an employee. The
Employee Leave Account window displays leave data for an employee, e.g., the employee’s
compensatory time for religious observance, family friendly leave data, etc.

The leave information recorded on the T&A is a method of maintaining an employee’s leave
record. It consists of leave brought forward from the prior pay period, leave earned during the
current pay period, leave used for the processing pay period, and the leave balance to date.

When an employee’s annual leave category changes, you must update the Annual Leave
Category field on the Employee window (Figure 36 ). If you forget to do this before preparing
a transmission file, you must revalidate the T&A. You can also make corrections to an
employee’s leave account at any time during the pay period.

Leave discrepancies involving leave errors within the current or previous 26 pay periods
should be resolved by preparing a corrected T&A. For leave discrepancies over 26 pay
periods, submitting a leave audit and correcting the database through TINQ is used to correct
the error. The leave correction is applied to the database in the pay period after the corrected
T&A is processed. The leave audit and TINQ are used as a last resort when correcting leave
errors. See the TINQ procedure for adjusting leave data in the database. For more
information on preparing a corrected T&A, see Preparing A Corrected T&A .

If an employee is on leave without pay (LWOP) for an entire pay period, but a personnel
action has not been processed on him/her, the Timekeeper must still prepare a T&A and
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transmit it to document the employee’s status for the pay period. If a personnel action has
been processed on the employee, there is no need for the Timekeeper to prepare a T&A. If an
action was cut, and employee returns to duty, the Timekeeper would click [Add New]  from
the employee’s Time And Attendance List window (Figure 40 ). The Select Pay Period
pop-up (Figure 56 ) appears, and the Timekeeper selects the appropriate pay period for the
employee’s return to duty.

Note:  When a full-time employee is in nonpay status or reaches a multiple of 80 hours of
nonpay status (any combination of LWOP, absent without official leave (AWOL),
suspension, furlough, etc.) during a pay period, the employee does not earn annual leave or
sick leave for that pay period. STAR computes this automatically so that no action on the
part of the user is necessary. This reduction in accruals does not apply to a part-time
employee because his/her leave accrual is based upon time in pay status each pay period.

Note:  Full-time employees in Leave Category 6 earn an additional 4 hours of annual leave
during the last full pay period of the calendar year, for a total of 10 hours of annual leave.
When an employee is in nonpay status or reaches a multiple of 80 hours of nonpay status
during the last full pay period of the calendar year, the employee does not earn annual leave
during the last full pay period of the calendar year; therefore, the employee does not earn the
additional 4 hours. STAR computes this automatically for employees in Leave Category 6 so
that no action on the part of the user is necessary.

For more information, see:

Adding Or Updating A Leave Type Record

Adding Or Updating An Employee Leave TypeRecord

You can add or update leave types for an employee’s leave account. For instructions on
deleting a leave type from the employee’s leave account, see Deleting Items In STAR .

To add or update a leave type record:

1. On the Employee List window (Figure 34 ), select the applicable employee and

click . The Employee Leave Account window (Figure 38 ) for that employee is
displayed.
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Figure 38. Employee Leave Account window

2. To add a leave type to the employee’s leave account, complete the fields as indicated
under Employee Leave Account Window Field Instructions .

OR

To update a leave type that has already been established in the employee’s leave
account, select the applicable leave type. The leave type selected will display in the
detail area.

Note:  After you add data into the detail area, the add function becomes available.

3. Click [Add]  to add the leave type record or [Update]  to update an existing leave type.

4. When adding a new employee, the Employee Leave Account window (Figure 38 ) is
displayed after adding the employee on the Employee window (Figure 36 ). If this the
first record for an employee in STAR, select each applicable leave type and
click [Update] . Updating the applicable leave types will eliminate leave balance errors.

Note:  If the employee was converted from PC-TARE, you do not need to [Update]  the
leave types. The Data Conversion process will perform this function.

Note:  The leave account for a new full-time or part-time employee is automatically
created with annual and sick leave if the accrual rate was not 0 on the Employee Leave
Account window (Figure 38 ). Therefore, if an employee has a balance greater than 0,
the Timekeeper must [Update]  the record.

Printing The Open Window

This option allows you to make a screen print of the open window.
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To print a record:

1. On the applicable window, click . The Print window (Figure 39 ) is displayed.

Figure 39. Print window

2. Complete the fields as indicated under Print Window Field Instructions .

3. Either click [OK]  to print the record or [Cancel]  to cancel the print job.
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T&A Maintenance

This section presents the following topics:

About T&A Maintenance

Preparing A T&A

Rolling Over T&A’s

Transmit T&A’s

Print Reports

About T&A Maintenance

T&A Maintenance is an option on the File menu. To select T&A Maintenance, select File >
T&A Maintenance  from the STAR menu bar. When a Timekeeper has access to more than one
contact point, the Contact Point List window (Figure 33 ) is displayed before the Employee

List window. You must select the desired contact point and click .

The Employee List window (Figure 34 ) is displayed with a list of all employees that are
maintained by a Timekeeper. The Timekeeper is responsible for adding, updating, and/or
deleting all employees assigned to his/her T&A Contact Point. From the Employee List
window (Figure 34 ), a Timekeeper can roll over all employees’ T&A’s to the next pay period.

By selecting the applicable employee and clicking  on the Employee List window,
Timekeepers can access the Time And Attendance List window (Figure 40 ), or the Biweekly
T&A window (Figure 41 ). The Time And Attendance List window provides a list by pay
period of all T&A’s for an employee while the Biweekly T&A window goes directly to the
active T&A. Timekeepers can navigate through the employee list on both windows by using

the SSN , NAME , SSN , and NAME  buttons. Timekeepers can also click  to go directly to the
employee’s T&A.
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Figure 40. Time And Attendance List window

Preparing A T&A

The Biweekly T&A option allows timekeepers to enter T&A data at any time during the pay
period rather than waiting until the end of the pay period.

To prepare a T&A:

1. Select File > T&A Maintenance  from the STAR Menu Bar. The Employee List 
window (Figure 34 ) is displayed.

2. Select the applicable employee and click  or  on the Employee List window. If

you clicked , the Time And Attendance List window (Figure 40 ) is displayed, or if

you clicked , the Biweekly T&A window (Figure 41 ) is displayed.

3. On the Time And Attendance List window (Figure 40 ), select the applicable record
and click [Add New] . The Biweekly T&A window (Figure 41 ) is displayed.
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Figure 41. Biweekly T&A window

4. Complete the fields as indicated under Biweekly T&A Window Field Instructions .

5. After completing the applicable fields for each TC line, click [Add] .

Note:  On the Prefix, TC, and Suffix fields, you can click  to display a list of
available TC’s. The Transaction Code Selection List pop-up (Figure 43 ) appears. For
more information on the Transaction Code Selection List pop-up, see Using The
Transaction Code Selection List Pop-up .

The Application Administrator controls the list of TC’s that can be utilized by a
Timekeeper, and normally filters out those that are not applicable. However, in the
event that a needed TC does not appear on the list, the Timekeeper should contact the
application administrator.

Note:  If you enter a TC that is a dollar amount TC, the Enter Total Dollar Amount 
pop-up (Figure 42 ) appears. For more information on the Enter Total Dollar Amount
pop-up, see Using The Enter Total Dollar Amount Pop-up .

Figure 42. Enter Total Dollar Amount pop-up
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6. To change a TC record, select the applicable TC in the list box. The TC record appears
in the detail area.

7. Make the applicable changes and click [Update] . The TC record is updated in the list
box.

Figure 43. Transaction Code Selection List pop-up

Note:  On the Accounting field, you can click  to display a list of accounting codes
from the Accounting Code table. The Accounting Code Selection List pop-up
(Figure 44 ) appears. For more information on the Accounting Code Selection List
pop-up, see Using The Accounting Code Selection List Pop-up .

Figure 44. Accounting Code Selection List pop-up

8. After preparing the T&A, click . If no error conditions exist on the T&A, the status
is changed to verified, and Verified  is displayed in the Status field. If any error
conditions exist, an error message will be displayed. The error must be corrected
before the T&A can be successfully verified. Only verified T&A’s can be transmitted.
As long as an error message is present, a T&A cannot be transmitted.

9. To prepare a T&A for another employee, click SSN , NAME , SSN , or NAME  to scroll on the

employee list, or type the SSN for the new employee in the SSN field and click .
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For more information see:

Using The Transaction Code Selection List Pop-up

Using The Accounting Code Selection List Pop-up

Using The Enter Total Dollar Amount Pop-up

Maintaining A Header Record

Changing A T&A

Preparing A Split T&A

Merging T&A Records

Preparing A Corrected T&A

Using The Transaction Code Selection List Pop-up

The Transaction Code Selection List pop-up (Figure 43 ) appears when you click  on the
Prefix, TC, and Suffix fields. The Transaction Code Selection List pop-up is used to display
a list of enabled TC’s available to the Timekeeper.

To select a TC, prefix, or suffix:

1. On the Biweekly T&A window (Figure 41 ), click . The Transaction Code Selection
List pop-up (Figure 43 ) appears.

2. Complete the fields as indicated under Transaction Code Selection List Pop-up Field
Instructions .

3. Click [Select]  to select the applicable TC or [Cancel]  to cancel the selection. You are
returned to the Biweekly T&A window after clicking [Select]  or [Cancel] .

To search for a TC on the Transaction Code Selection List pop-up:

1. On the Biweekly T&A window (Figure 41 ), click . The Transaction Code Selection
List pop-up (Figure 43 ) appears.

2. Select Edit > Search . The Transaction Code Selection List Search pop-up (Figure 45 )
appears.

Figure 45. Transaction Code Selection List Search pop-up
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3. Complete the fields as indicated under Transaction Code Selection List Search
Pop-up Field Instructions .

4. Click [Find]  to search for the TC or [Cancel]  to cancel the search and return to the
Transaction Code Selection List pop-up.

Using The Accounting Code Selection List Pop-up

The Accounting Code Selection List pop-up (Figure 44 ) appears when you can click  on
the Accounting field. The Accounting Code Selection List pop-up is used to select
accounting codes from the accounting code table in STAR.

To select an accounting code:

1. On the Biweekly T&A window, click . The Accounting Code Selection List
pop-up appears.

2. Complete the fields as indicated under Accounting Code Selection List Pop-up Field
Instructions .

3. Click [Select]  to select the applicable accounting code or [Cancel]  to cancel the
selection. You are returned to the Biweekly T&A window after clicking [Select]  or
[Cancel] .

To search for an accounting code on the Account Code Selection List Pop-up:

1. On the Biweekly T&A window, click . The Accounting Code Selection List
pop-up appears.

2. On the Accounting Code Selection List pop-up, select Edit > Search . The Accounting
Code Selection List Search pop-up (Figure 46 ) appears.

Figure 46. Accounting Code Selection List Search pop-up

3. Complete the fields as indicated under Accounting Code Selection List Search Pop-up
Field Instructions .

4. Click [Find]  to search for the applicable accounting code or [Cancel]  to cancel the
search and return to the Accounting Code Selection List pop-up.

Using The Enter Total Dollar Amount Pop-up

The Enter Total Dollar Amount pop-up (Figure 42 ) appears when you enter a dollar TC in
Prefix, TC, and Suffix fields on the employee’s T&A. This pop-up is used to enter a dollar
amount for those TC’s that are recorded in dollars and cents.
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1. On the employee’s Biweekly T&A window (Figure 41 ), enter the appropriate dollar
amount TC in the applicable Prefix, TC, and Suffix fields. The Enter Total Dollar
Amount pop-up appears.

2. Complete the Dollar Amount field as indicated under Enter Total Dollar Amount
Pop-up Field Instructions .

3. Click [OK]  to return to the Biweekly T&A window.

Maintaining A Header Record

This option allows you to maintain a header record for an employee.

To maintain a header record:

1. On the employee’s Biweekly T&A window, click . The Update Header 
pop-up (Figure 47 ) appears.

Figure 47. Update Header pop-up

2. Complete the fields as indicated under Update Header Pop-up Field Instructions .

3. Click [OK]  to update the header record or [Cancel]  to cancel the function. After
clicking [OK]  or [Cancel] , you are returned to the Biweekly T&A window. 

Changing A T&A

This option is used to update or change a T&A before it is transmitted. You can make
changes to the T&A header record, the employee’s leave account, or the employee’s T&A. If
the T&A has already been transmitted, you must use the Correct T&A  option. For more
information on the Correct T&A  option, see Preparing A Corrected T&A .

To change a T&A:

1. On the Employee List window, select the applicable employee and click  or . If

you clicked , the Time And Attendance List window (Figure 40 ) for that employee



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

60 Updated 9/12/03

is displayed, or if you clicked , you are brought directly to the Biweekly T&A
window (Figure 41 ).

2. On the Time And Attendance List window, select the record to be changed and 
click [Change] . The Biweekly T&A window is displayed.

3. If you are changing a TC line, select the applicable line, make the desired change(s),
and click [Update] .

OR

Add the applicable TC line and click [Add] .

OR

Delete the applicable TC line and click [Delete] .

4. After all changes are made, click  to verify the T&A.

Preparing A Split T&A

This option is used to prepare a split T&A. A split T&A is prepared when a change occurs
during the pay period and different variables are applied to part of the pay period (i.e., LWOP
balance). A split T&A requires the completion of two T&A’s. When preparing a split T&A,
enter the day before the change was effective in the Split Part 1 End Day field and the
effective day of the change in the Split Part 2 Begin Day field.

Note:  If one of the split T&A’s contains an error, both T&A’s will reject.

To prepare a split T&A:

1. On the Employee List window (Figure 34 ), select the applicable employee and click

. The Time And Attendance List window (Figure 40 ) for that employee is
displayed.

2. Select the applicable record and click [Split Selected T&A]  on the Time And
Attendance List window. A Confirm Split pop-up (Figure 48 ) appears.

Figure 48. Confirm Split pop-up

3. Click [Yes]  to split the T&A or [No]  to cancel the split. If you click [Yes] , the Split
T&A Information pop-up (Figure 49 ) appears.
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Figure 49. Split T&A Information pop-up

4. Complete the fields according to the instructions under Split T&A Information Pop-up
Field Instructions .

5. On the Split T&A Information pop-up (Figure 49 ), click [Continue]  to continue
preparing the split T&A or [Cancel]  to cancel the function. If you click [Continue] , the
T&A will appear on the Time And Attendance List window (Figure 40 ) on two lines,
one for each part of the T&A.

Note:  It is recommended that you complete both parts of a split T&A before verifying

the T&A. Clicking  on either part of the T&A, verifies both T&A’s.

Merging T&A Records

This option is used to cancel a split T&A.

To merge:

1. On the Employee List window (Figure 34 ), select the applicable employee and

click . The Time And Attendance List window (Figure 40 ) for that employee is
displayed.

2. Select either record of a split T&A on the Time And Attendance List window and
click [Merge] . The T&A is merged back into a regular T&A.

3. Update the T&A to reflect the hours originally listed on Part 1 of the T&A.

Note:  The merge process does not combine Part 1 and Part 2 TC’s. Only the data from
Part 2 of the split is retained. You must update the T&A to reflect the correct
information after choosing the merge option.

Preparing A Corrected T&A

This option is used to prepare a corrected T&A for a transmitted T&A from the T&A list.
You can correct the T&A header record, the employee’s leave account, an employee’s detail
record, or the employee’s T&A. Corrected T&A’s are prepared for T&A’s that have been
transmitted for the current and last 25 pay periods. If the T&A has not yet been transmitted,
you must use the Change  option. For more information on the Change  option, see Changing
A T&A .
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To prepare a corrected T&A:

1. On the Employee List window (Figure 34 ), select the applicable employee and 

click . The Time And Attendance List window (Figure 40 ) for that employee is
displayed.

2. Select the applicable T&A and click [Correct T&A] . The Biweekly T&A 
window (Figure 41 ) is displayed.

3. Select the TC line to be corrected, make the applicable changes, and click [Update] .

OR

Add the applicable TC line and click [Add] .

OR

Select the TC line to be deleted and click [Delete] .

4. After all corrections are made, click  to re-verify the T&A.

Rolling Over T&A’s

This option allows the Timekeeper to create a new pay period for all employee records on the
employee list that were successfully transmitted the previous pay period. To advance the pay

period number, click  on the Employee List window (Figure 34 ). The Rollover
pop-up (Figure 50 ) appears. For more information on using the Rollover pop-up, see
Rollover Pop-up Description .

Figure 50. Rollover pop-up

To roll over T&A’s:

1. On the Employee List window, click . The Rollover pop-up (Figure 50 ) appears.

2. Click [Yes]  to roll over to the next pay period.

OR

[No]  to cancel the rollover.

3. If you click [Yes] , the Pay Period List pop-up (Figure 51 ) appears.
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Figure 51. Pay Period List pop-up

To select the pay period to roll over T&A’s:

1. At the Rollover pop-up (Figure 50 ), click [Yes] .

2. Select the applicable pay period.

3. Click [OK]  to roll over the pay period or [Cancel]  to cancel the roll over. After
clicking [OK]  or [Cancel] , you are returned to the Employee List window (Figure 34 ).
For more information about the Pay Period List pop-up, see Pay Period List Pop-up
Field Instructions .

Transmit T&A’s

Transmit is used by the Transmitter to prepare a file of T&A’s to be transmitted to NFC. To
prepare a transmission file, select File > Transmit  on the STAR Menu Bar. The Prepare
Transmit File window (Figure 52 ) is displayed. If a Transmitter has access to more than one
contact point, the Contact Point List window (Figure 33 ) is displayed. You must select the

applicable contact point record and click . The Prepare Transmit File window is
displayed. The Prepare Transmit File window displays an employee list in alphabetical order.
You can change the sort to SSN by selecting View > Sort By SSN .

Note:  The Prepare Transmit File window can also be accessed from the Biweekly T&A
window (Figure 41 ) and the Time And Attendance List window (Figure 40 ).
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Figure 52. Prepare Transmit File window

For more information, see:

Transmitting T&A’s

Confirming The Transmission

Transmitting T&A’s

This option allows the Transmitter to prepare a transmission file for all T&A’s for a contact
point or for a selected T&A(’s) for a contact point. As the T&A transmission file is prepared,
the Status field for each employee on the list will be identified as Transmitted, and the Total
Xmit T&A field will be updated.

To prepare a T&A transmission file:

1. Select File > Transmit  from the STAR Menu Bar. The Select Pay Period 
pop-up (Figure 56 ) appears.

2. Select the applicable pay period and click [OK]  to prepare the transmission file or
[Cancel]  to return to the STAR Menu Bar.

3. The Prepare Transmit File window (Figure 52 ) for the applicable pay period is
displayed.

4. Complete the fields as indicated under Prepare Transmit File Window Field
Instructions .

5. To prepare a transmission file for all the T&A’s for a contact point, click [Xmit All]  on
the Prepare Transmit File window, or to prepare a transmission file for a single T&A
or a group of T&A(s) for a contact point, select the employee(s) for whom you wish to



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

P
art N

O
 TA

G
T

&
A

 M
aintenance

65Updated 9/12/03

prepare the transmission file and click [Xmit Selected]  on the Prepare Transmit File
window. The Transmit Password pop-up (Figure 53 ) appears, if the Use JCL field was
checked on the Prepare Transmit File window (Figure 52 ).

6. To prepare a transmission file for only those T&A’s that have a verified status, the
Verified Only box must be checked on the Prepare Transmit File window 
(Figure 52 ).

Note:  You can remove data from the transmit file by selecting Edit > Wipe Xmit File .

Figure 53. Transmit Password pop-up

To define the transmission password:

1. On the Prepare Transmit File window (Figure 52 ), click [Xmit Selected]  or [Xmit All] .
The Transmit Password pop-up (Figure 53 ) appears.

2. Complete the fields as indicated under Transmit Password Pop-up Field Instructions .

3. Click [OK]  to continue to prepare the transmit file or [Cancel]  to cancel the transmit. If
you click [OK] , the Save Transmit File As pop-up (Figure 54 ) appears.

Figure 54. Save Transmit File As pop-up
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To save the transmission file:

1. On the Transmit Password pop-up (Figure 53 ), click [OK] . The Save Transmit File As
pop-up (Figure 54 ) appears.

Note:  The Transmit Password pop-up only appears if the Use JCL field box is checked
on the Prepare Transmit File window (Figure 52 ). If this box is left blank, you will
skip to Step 2.

2. Complete the fields as indicated under Save Transmit File As Pop-up Field
Instructions .

3. Click [Save]  to save the transmit file or [Cancel]  the save and return to the Transmit
Password pop-up.

Note:  You may append an existing transmission file if it has not been transmitted and
confirmed. If it has been transmitted, but not confirmed, a new file should be created.
When you prepare a transmission file for an existing file, be advised that each time a
file to be transmitted to NFC is created, the previous data will overwritten, even if the
data has not yet been transmitted to NFC. Therefore, if you must prepare a second
transmission file before the first one is transmitted to NFC, you should either rename
the file or copy the first transmission file onto a disk. You must indicate the applicable
drive in the filename.

Confirming The Transmission

NFC confirms receipt of T&A data by transmitting a confirmation report(s) to the designated
printer listed in the JCL. If this report is not received, the user should check the status of the
transmission file (file), as described below in Checking Job Status.

To verify the T&A data transmitted against the data received by NFC, a confirmation report
should be printed at your location after each transmission. For more information on the
Confirmation Report, see Reporting . Be sure to match job numbers from the transmission
and the confirmation.

Preceding the confirmation report is the JCL printout, which provides information relating to
the file (job) that has been transmitted. The first page of the JCL printout is composed of the
job number, job name, remote device number, and comments established by the STAR
administrator. The information is printed 6 times.

Immediately following the JCL printout is a 3-page report, JES2 Job Log-System
SYSB-NODE NFC. This report indicates if transmission is complete, incomplete, or
abended. If abended, an abend code (ABEND###) is provided indicating the reason for the
code. If a confirmation report indicates that a transmission was abended, corrective action
must be taken to ensure that the T&A’s are retransmitted to NFC. If the Transmitter does not
know how to resolve a particular abend code, he/she should contact his/her agency
coordinator immediately.

The confirmation transmittal contains total hours, TC, and T&A totals.

The confirmation report follows the JES2 report and consists of 2 pages. This report should
be used to verify T&A transmissions.
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The Job Performance Report for Time### displays the steps involved in the transmission
process. The message Job Has Completed Successfully indicates that the job has been
completely transmitted. This report should also be given to the timekeeper(s) to verify
transmission(s).

The End Job page (last page printed) is composed of JCL and indicates the end of the
information from NFC regarding your transmission.

Note:  Do not discard or misplace the Confirmation Report. It can be requested only once.

Print Reports

Print Reports is an option on the File menu. This option is used to print T&A’s. When a
Timekeeper has access to more than one contact point, the Contact Point List 
window (Figure 33 ) is displayed. You must select the desired contact point and either click

 to display the Employee List window (Figure 34 ) or click . If the employee has access
to only one contact point, select File > Print Reports  from the STAR Menu Bar. The Print
Reports window (Figure 55 ) is displayed. The Print Reports window is sorted alphabetically
by last name. If you wish to change the sort to sort the employees by SSN, select Edit > Sort
By SSN .

Figure 55. Print Reports window

Note:  The Print Reports window (Figure 55 ) can also be accessed from the Biweekly T&A 
window (Figure 41 ) and the Time And Attendance List window (Figure 40 ).

For more information, see:

Printing T&A’s
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Printing T&A’s

This option allows you to print T&A’s. You can print all of the T&A’s for a contact point or a
selected group of T&A’s for a contact point. The status counts box displays the new, in
progress, error, verified, and transmitted T&A’s. The SSN of the T&A being printed is
updated as T&A’s are printed.

To print T&A’s:

1. Select File > Print Reports  from the STAR Menu Bar. The Select Pay Period 
pop-up (Figure 56 ) appears.

Figure 56. Select Pay Period pop-up

2. Select the applicable pay period and click [OK]  to proceed to print or [Cancel]  to return
to the STAR Menu Bar.

3. The Print Reports window (Figure 55 ) is displayed.

4. For instructions on specifying the format in which you want the records printed, see
Print Reports Window Field Instructions .

5. To print all of the T&A’s for a contact point, click [Print All]  on the Print Reports
window.

OR

To print a selected group of T&A’s, select the applicable T&A(s) and click [Print
Selected]  on the Print Reports window. The Reporting pop-up (Figure 57 ) appears
displaying the selected T&A’s.

OR

To only print T&A’s that have a verified status, the Verified Only box must be
checked on the Print Reports window (Figure 55 ).
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Figure 57. Reporting pop-up

6. Click  to print T&A’s.
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Field Instructions for Getting Started in STAR

This section presents the following topics:

Logon Pop-up Field Instructions

Logon Pop-up Field Instructions

The Logon pop-up (Figure 2 ) appears when you select Start > National Finance
Center > Star  from the Start menu. This pop-up is used to log on to the STAR
application. For instructions on using the Logon Pop-up, see Logging On .

User Id
Type your STAR user identification number (user ID). Your user ID is not
displayed in this field.

Required, alphanumeric, 8 positions max.
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Field Instructions for System Maintenance

Contact Point Maintenance Window Field Instructions

Contact Point Search Pop-up Field Instructions

Build JCL Window Field Instructions

Authorized User List Window Field Instructions

User Permissions Window Field Instructions

Authorized User Search Pop-up Field Instructions

Data Conversion Window Field Instructions

Contact Point List For Backup/Restore Processing Pop-up Field Instructions

Backup Path Pop-up Field Instructions

Backup Pop-up Field Instructions

Restore Pop-up Field Instructions

Open Pop-up For Restore Field Instructions

Automatic Backup Directory Pop-up Field Instructions

Import/Export Window Field Instructions

Export Path/File Name Pop-up Field Instructions

Open Pop-up For Import Field Instructions

Archive Pop-up Field Instructions

Archive Path Pop-up Field Instructions

Contact Point Maintenance Window Field Instructions

The Contact Point Maintenance window (Figure 7 ) is displayed when you select
System > Contact Point  from the STAR Menu Bar. This window is used to add,
view, modify, delete, or print STAR contact point records. For instructions on
using the Contact Point Maintenance window, see Adding Or Updating A Contact
Point Record .

Contact Point
List

This field is system generated. A list of contact points is displayed in this field.
Contact Points are entered by the User Administrator.

Detail

Agency
Type the user’s agency code. This code can be found in TMGT, Table 023,
Agency/Bureau. This table contains the agency/bureau code, the servicing
agency/bureau code, and the name of the agency/bureau. If you are unsure of your
agency code, contact your System Administrator or T&A Coordinator.

State Code
Type the code that identifies the user’s state (within or outside the continental
United States). A list of state codes is contained in the GSA Worldwide

No entry

∇

Required, alphanumeric, 2 positions

Required, numeric, 2 positions
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Geographic Location Codes Handbook, on the Internet at www.opm.gov, and in
TMGT, Table 016, Geographic Location Codes with Names. If you are unsure of
your state code, contact your System Administrator or T&A Coordinator.

Town
Type the user’s town code contained in the GSA Worldwide Geographic Location
Codes Handbook or on the Internet at www.opm.gov. If a city code is not listed in
the GSA handbook, contact your personnel office to obtain the code. If you are
unsure of your town code, contact your System Administrator or T&A
Coordinator.

Unit
Type the agency-assigned number that identifies the unit. The unit code identifies
each contact point location within a town. If you are unsure of your unit code,
contact your System Administrator or T&A Coordinator.

TK Number
Type the agency-assigned number that identifies the timekeeper. If you are unsure
of your Timekeeper number, contact your System Administrator or T&A
Coordinator.

Street 1
Type the first line of the organization’s address.

Street 2
Type the second line of the organization’s address.

City
Type the organization’s city.

St
Type the alpha 2-character state abbreviation.

Zip
Type the organization’s ZIP+4 code.

Phone
Type the organization’s phone number, including area code. The telephone
number must be typed in the XXX-XXX-XXXX format.

Comp Time
Rollover

Click this box to roll over your compensatory time. Compensatory time earned
may be liquidated by the end of the leave year, carried forward to the following
year, or paid in full. Follow your agency policy regarding compensatory balances
at the end of the leave year. A check will appear in this box. If this box is left
blank, the compensatory time balance is zeroed out at the beginning of the new
leave year. If you are unsure of your agency policy or procedure, contact your
personnel office. If your agency issues payment when compensatory time is
zeroed out, you must submit Form AD-581, Lump Sum Leave Or Compensatory
Time Payments.

Acctg Rollover
This field is reserved for future use.

Required, numeric, 4 positions

Required, numeric, 2 positions

Required, numeric, 2 positions

Required, alphanumeric, 20 positions max.

Optional, alphanumeric, 20 positions max.

Required, alphanumeric, 20 positions max.

Required, alpha, 2 positions

Required, numeric, 5 positions required, 4 positions optional

Required, numeric, 12 positions

Optional

No entry
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Daily Biweekly
Preference

This field is reserved for future use.

Any Timekeeper
Entry Flag

This field is reserved for future use.

Can Someone
Enter Own Time

This field is reserved for future use.

Entry Approval
Preference Flag

This field is reserved for future use.

Contact Point Search Pop-up Field Instructions

The Contact Point Search pop-up (Figure 2 ) appears when you click  on the
Contact Point Maintenance window (Figure 7 ). This pop-up is used to search for a
contact point record. For instructions on using the Contact Point Search
Pop-up (Figure 8 ), see Searching For A Contact Point Record .

Agency
Type the agency code. This code can be found in TMGT, Table 023,
Agency/Bureau. This table contains the agency/bureau code, the servicing
agency/bureau code, and the name of the agency/bureau. If you are unsure of your
agency code, contact your System Administrator or T&A Coordinator.

State
Type the state code (inside or outside the Continental United States). A list of
state codes is contained in the GSA Worldwide Geographic Location Codes
Handbook, on the Internet at www.opm.gov, and in TMGT, Table 016,
Geographic Location Codes with Names. If you are unsure of your state code,
contact your System Administrator or T&A Coordinator.

Town
Type the town code. This code can be found in the GSA Worldwide Geographic
Location Codes Handbook or on the Internet at www.opm.gov. If a city code is not
listed in the GSA handbook, contact your personnel office to obtain the code. If
you are unsure of your town code, contact your System Administrator or T&A
Coordinator.

Unit
Type the agency-assigned number that identifies the unit. The unit code identifies
each contact point location within a town. If your are unsure of your unit code,
contact your System Administrator or T&A Coordinator.

Timekeeper
Type the agency-assigned number that identifies the timekeeper. If you are unsure
of your Timekeeper code, contact your System Administrator or T&A
Coordinator.

No entry

No entry

No entry

No entry

Required, alphanumeric, 2 positions

Optional, numeric, 2 positions

Optional, numeric, 4 positions

Optional, numeric, 2 positions

Optional, numeric, 2 positions
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Build JCL Window Field Instructions

The Build JCL window (Figure 9 ) is displayed when you select System > JCL
from the STAR Menu Bar. This window is used by the Transmitter to establish or
change the JCL and to input an entry which allows the password to be edited. If
you are going to use JCL when transmitting files to NFC, the JCL must reflect
your agency’s specifications before transmission. It is recommended that you
review the Confirmation Report to make sure that files were successfully
transmitted. For instructions on JCL, see Building JCL .

Data For JCL

Test/Prod
For a list valid values, see Test/Prod Table .

The JCL files can be changed to send transmission files as a test (i.e., transmitted
T&A’s are not processed through production files by NFC), or the JCL file can
be changed to send transmission files to production (i.e., transmitted T&A’s are
processed through production files by NFC).

Note:  Agencies should be advised that when changing from test to production, the
first two characters of the job name must be entered in the Job Name field. STAR
automatically moves to the Job Card Name field upon entering PROD.

Example:

This option allows all T&A’s for each location to be combined for one
transmission. After you type your entry, the cursor moves to the Job Card
Comments field. If TEST is entered, the cursor moves to the Remote Number
field.

Remote Number
Type local , unless you have a specific printer ID assigned by NFC. If you type
local , the report will print on the mainframe at NFC.

Job Name
This field is initially blank. To change to production, the first two characters of
the job name must be entered in this field. For USDA agencies, type FP. For
non-USDA agencies, type the two characters assigned to your agency. When
changing from production to test, the system generates this field, and no entry is
allowed. After the first 2 positions, the remainder of this field is system
generated.

Job Card
Comments

This field is for agency use, as needed, such as for telephone number, initials, etc.

Note:  This field accepts no hyphens, periods, etc.

∇

Required, alpha, 4 positions

Conditional, alphanumeric, 16 positions max.

Optional, alphanumeric, 2 positions

Optional, alphanumeric, 16 positions max.
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Don’t Transmit
User/ID
Password

Click this field if you don’t want to transmit the user ID and/or password. A
check mark will appear in this box. The default is the box with no check mark
(blank).

Job Control
Language

This group of fields is system generated based on the information entered in the
above fields and the user ID and password utilized to transmit actual T&A’s. JCL
information is entered by Transmitters.

Authorized User List Window Field Instructions

The Authorized User List window (Figure 10 ) is displayed when you select
System > Authorized Users  from the STAR Menu Bar (Figure 5 ). This window
displays a list of authorized STAR users set up in PRMS. This window allows the
System Administrator to search for an authorized user, display a list of authorized
users, and display available and selected T&A Contact Points for a given user.
For more information on authorizes users, see Adding/Removing A Contact
Point(s) On The Selected List .

Athorized User
List

This field is system generated based on the authorized users set up by the System
Administrator. The user ID and name are displayed in this field.

User Permissions Window Field Instructions

The User Permissions window (Figure 11 ) is displayed when you select an

authorized user from the Authorized User List window (Figure 10 ) and click .
This window displays a list of available contact point(s) for an authorized user.
For more information on authorized users, see Adding/Removing A Contact
Point(s) On The Selected List .

User ID
This field is system generated based on the user selected on the Authorized User
List window. The user ID of the user selected is displayed in this field.

Name
This field is system generated based on the user selected on the Authorized User
List window. The name of the user selected is displayed in this field.

Optional

No entry

No entry

No entry

No entry
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Available/Selecte
d List

These lists are system generated based on the contact point(s) set up for an
authorized user. The System Administrator can move the contact points from the
Available List to the Selected List.

Authorized User Search Pop-up Field Instructions

The Authorized User Search pop-up (Figure 12 ) appears when you click  on
the Authorized User List window (Figure 10 ). This pop-up allows users to search
for an authorized STAR user. For instructions on using the Authorized User
Search pop-up, see Searching For An Authorized User .

User ID
Type the applicable user ID of the user for whom you are searching.

Data Conversion Window Field Instructions

The Data Conversion window (Figure 13 ) is displayed when you select
System > Data Conversion  from the STAR Menu Bar. The data conversion
function is used by the Timekeeper to convert data from PC-TARE to STAR. For
instructions on using the Data Conversion window, see Data Conversion .

Conversion Type
Select the applicable radio button to designate which version of PC-TARE from
which you wish to convert data.

List Box
Select the applicable pay period for the data to be converted. Only one pay period
at a time can be converted. This list box displays the available pay periods and
the corresponding begin dates.

Contact Point List For Backup/Restore Processing Pop-up Field
Instructions

The Contact Point List For Backup/Restore Processing pop-up (Figure 14 )
appears when you select System > Backup/Restore  from the STAR Menu Bar.
The Contact Point List For Backup/Restore Processing pop-up is used by the
System Administrator to access the backup and restore functions. For instructions
on using the Contact Point List For Backup/Restore Processing pop-up, see
Backup/Restore .

Contact Point
List

This field is system generated. A list of contact points for that System
Administrator is displayed in this box.

No entry

Required, alphanumeric, 5-8 positions

Required

Required

No entry
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Backup Path Pop-up Field Instructions

The Backup Path pop-up (Figure 15 ) appears when you click [Proceed With
Backup]  on the Contact Point List For Backup/Restore Processing pop-up. The
Backup Path pop-up is used by the System Administrator to define the path for
the file being backed up. For instructions on using the Backup Path pop-up, see
Backing Up Data .

Path
Type the path of the file to be backed up. Do not type the \  (backslash) when
typing the path. STAR provides the backslash.

Backup Pop-up Field Instructions

The Backup pop-up (Figure 16 ) appears when you click [OK]  on the Backup Path
pop-up (Figure 15 ). The Backup pop-up is used by the System Administrator to
back up data. For instructions on using the Backup pop-up, see Backing Up Data .

Backup Options
Select the applicable radio button to designate the backup option. For a list of the
valid values and definitions of the values, see Backup Options Table .

Restore Pop-up Field Instructions

The Restore pop-up (Figure 17 ) appears when you click [Proceed With Restore]
on the Contact Point List For Backup/Restore Processing pop-up (Figure 14 ). The
Restore pop-up is used by the System Administrator to restore data that was
accidentally deleted. For instructions on using the Restore pop-up, see Restoring
Data.

Note:  You can only restore data that has been backed up or archived.

The T&A Restore Criteria segment of the Restore pop-up is only used if you are
restoring partial T&A data. Partial T&A data is data for a particular employee for
one pay period for a particular contact point.

Select T&A
Restore Type

Select the applicable radio button to designate the restore type. For a list of the
valid values and definitions of the values, see Select T&A Restore Type Table .
This field defaults to None (T&A) .

Required, alphanumeric, 50 positions max.

Optional

Required
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T&A Restore Criteria

List Box
A list of available contact points is displayed in this field. Select the applicable
contact point.

Employee

Click  to display the employee list. Select the applicable employee. You can
only restore one employee at a time.

Pay Period

Click  to display the available pay periods. Select the applicable pay period.
You can only restore data for the selected employee for one pay period at a time.

Year
This field is system generated. The 4-digit year applicable to the T&A being
restored is displayed in this field. The pay period selected generates the applicable
year.

Select Table
Restore Type

Select the applicable radio button to designate the restore type. For a list of valid
values and definitions of the values, see Select Table Restore Type Table . This
field defaults to None.

Note:  You may select more than 1 table in any given restore process; however, the
system will prompt you to individually select the appropriate file for each table
restoration.

Table Restore
Criteria

Accounting
Click this field to restore accounting table data. A check mark appears in this box.
This field is used if you are restoring a selected table(s).

Contact Point
Click this field to restore contact point data. A check mark appears in this box.
This field is used if you are restoring a selected table(s).

Leave
Click this field to restore leave table data. A check mark appears in this box. This
field is used if you are restoring a selected table(s).

Pay Period
Click this field to restore pay period table data. A check mark appears in this box.
This field is used if you are restoring a selected table(s).

Transaction
Codes

Click this field to restore TC table data. A check mark appears in this box. This
field is used if you are restoring a selected table. When restoring a selected table,
you can only restore one table at a time.

∇

Conditional

Conditional

Conditional

No entry

Required

∇

Conditional

Conditional

Conditional

Conditional

Conditional
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Open Pop-up For Restore Field Instructions

The Open pop-up (Figure 18 ) appears when you click [Continue]  on the Restore
pop-up (Figure 17 ). The Open pop-up is used to select the file(s) to be restored.
Only file(s) that have been backed up or archived can be restored. For more
information on using the Open pop-up when restoring file(s), see Restoring Data .

Note:  You must complete the Files Of Type field first in order to correctly
complete the remaining fields.

Look In
Click ][  to locate the file(s) to be restored.

List Box
This field displays a list of folders. Double click the Backup folder to select the
file to be restored. Only 1 file can be restored at a time.

File Name
From the applicable open folder in the list box, select the file to be restored. You
can only restore one file at a time.

Files Of Type
Click ][  to change this field to All Files. After selecting All Files , you
can view all of the files available for restore. This field defaults to Text
Files

Open As Read
Only

Click this box to open the file as read only. A check mark appears in this box.

Automatic Backup Directory Pop-up Field Instructions

The Automatic Backup Directory pop-up (Figure 19 ) appears when you select
System > Auto Backup Directory  from the STAR Menu Bar. The Automatic
Backup Directory pop-up allows users to select the drive and path to back up the
database file. For instructions on using the Automatic Backup Directory pop-up,
see Automatic Backup .

Specify Path For
Automatic
Backup

Type the drive and path in which you wish to back up the database file. It is
recommended that you do not save this backup to the A drive because the
database file may become too large and may not be able to fit on a diskette.

Required

Required

Required

Required

Optional

Required, alphanumeric, 80 positions max.
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Import/Export Window Field Instructions

The Import/Export window (Figure 20 ) is displayed when you select
System > Import/Export  from the STAR Menu Bar. The import function is used
by the System Administrator to import tables to various PC’s after they have been
established on the STAR database. The export function is used to transfer table
data onto a disk for import. For instructions on using the Import/Export window,
see Import/Export .

Table List
This field is system generated. A list of available tables and a description of each
table is displayed in this field.

Export Path/File Name Pop-up Field Instructions

The Export Path/File Name pop-up (Figure 21 ) appears when you click  on
the Import/Export window (Figure 20 ). The System Administrator uses the
Export Path/File Name pop-up to export table data onto disks. For instructions on
using the Export Path/File Name pop-up, see Exporting A File .

Path And File
Name

Type the path and file name for the file to be exported onto the disk. The
directory (drive) and file name should be included in the path, e.g., A:/Acctg
to export the Accounting Code Table to Drive A.

Open Pop-up For Import Field Instructions

The Open pop-up (Figure 18 ) is displayed when you click  on the
Import/Export window. The System Administrator uses the Open pop-up to
import table data to various PC’s. For instructions on using the Open pop-up
when importing table files, see Importing A File .

Look In
Click ][  to select the location of the file to be imported.

File List
This field is system generated. A list of available files is displayed in this field.

File Name
Type the name of the file to be imported.

No entry

Required, alphanumeric, 50 positions max.

Required

No entry

Required, alphanumeric, 37 positions max.
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Files Of Type
Click ][  to select a file type. Valid values are Text Files  and All
Files . If you select All Files , you can choose from all available files. If
you select Text Files , only files with a .txt  ending will be available.
Only ASCII text files can be imported.

Open As Read
Only

Click this field to designate the file to be opened as read-only. A check mark
appears in this box.

Archive Pop-up Field Instructions

The Archive pop-up (Figure 22 ) appears when you select System > Archive  from
the STAR Menu Bar. The Archive pop-up is used by the System Administrator or
Timekeeper to archive STAR data. For more information on archiving STAR
data, see Archiving Data .

Archive List Box
A list of available contact points is displayed in this field. Select the applicable
contact point.

Pay Period

Click  to display the Archive Pay Period List pop-up (Figure 23 ). The Archive
Pay Period List pop-up displays a list of all pay periods. Select the applicable pay
period to be archived and click [Select] .

Note:  Not all pay periods are available for archive. Only pay periods with STAR
data can be archived.

Note:  If no pay periods are selected, all T&A’s for the selected employee(s) will
be achieved.

Year
This field is system generated. The 4-digit year of the file being archived is
displayed in this field.

Employee
Type the applicable SSN to be archived and click  [Continue] .

Archive Path Pop-up Field Instructions

The Archive Path pop-up (Figure 24 ) appears when you click[Continue]  on the
Archive pop-up. The Archive Path pop-up is used to define the path and file name
for the file being archived. For more information on the Archive Path pop-up, see
Archiving Data .

Required, alpha,

Optional

Required

Required

No entry

Optional
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Path And File
Name

Type the path and file name of the file being archived.
Required, alphanumeric, 52 positions max.
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Field Instructions for Tables Windows

Accounting Code List Window Field Instructions

Accounting Code Search Pop-up Field Instructions

Accounting Code Rollover Pop-up Field Instructions

Transaction Code Search Pop-up Field Instructions

Transaction Code List Window Field Instructions

Pay Period List Window Field Instructions

Leave Type Search Pop-up Field Instructions

Leave Type List Window Field Instructions

Accounting Code List Window Field Instructions

The Accounting Code List window (Figure 25 ) is displayed when you select
Tables > Accounting  from the STAR Menu Bar. The Accounting Code table is
used to establish and edit accounting codes for use on the T&A. The accounting
codes used in STAR must correspond with those established in the Management
Account Structure Codes System (MASC). If accounting codes are present in the
table, then an accounting code edit is activated. This edit prevents a TC line from
accepting accounting when stored accounting is used or when the accounting code
entered is not on the table. The Accounting table can be customized for your
agency by adding your agency’s valid accounting codes. The format of
accounting codes in the table, on the T&A, and in MASC must agree. Your
System Administrator can import accounting codes from another STAR user, and
your Application Administrator can add individual accounting codes directly to
the table. For instructions on adding accounting codes to the Accounting Code
table, see Adding Or Updating An Accounting Code .

Accounting Code
List Box

This field displays a list of accounting codes used by the agency. These codes are
entered by the Application Administrator or imported by the System
Administrator.

Category
Type the accounting code. These codes are used to record the appropriation and
accounting information that is used to disburse and charge the employee’s pay
and related expenditures to the proper accounting.

Note:  If an agency uses stored accounting, the first time a Timekeeper prepares a
T&A for an employee, the Accounting Data Usage Code on the employee’s
header record (Figure 47 ) should be a 1 for stored accounting on the first line
with accounting entered on the first TC line on the employee’s T&A. The
following pay period, the Accounting Data Usage Code should be a 2 to use
stored accounting.

No entry

Required, numeric, 35 positions max.
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Description
Type the accounting classification code description.

Accounting Code Search Pop-up Field Instructions

The Accounting Code Search pop-up (Figure 26 ) appears when you click  on
the Accounting Code List window (Figure 25 ). This pop-up is used to search for
an accounting code on the Accounting Code Table. For instructions on using the
Accounting Code Search pop-up, see Searching For An Accounting Code .

Category
Type the category of the accounting code for which you are searching. If you
enter data into this field, leave the description field blank.

Description
Type the description of the accounting code for which you are searching. If you
enter data into this field, leave the category field blank.

Accounting Code Rollover Pop-up Field Instructions

The Accounting Code Rollover pop-up (Figure 27 ) is displayed when you select
Edit > Rollover Accounting  from the Accounting Code List window (Figure 25 ).
The Accounting Code Rollover pop-up is used to roll over accounting codes on
the Accounting Code table from the current fiscal year to the ensuing fiscal year.
This is done by replacing the current fiscal year indicators with indicators for the
ensuing fiscal year. Once the fields are completed, a new list of accounting codes
is developed. The current year accounting codes are still present. The current year
accounting codes must be deleted if you wish to remove them from the
accounting code table. For instructions on rolling over accounting codes, see
Rolling Over An Accounting Code .

Change From
Type the number(s) to be changed in the indicated positions. These are the
indicators for the current fiscal year.

Change To
Type the new number(s) for the ensuing fiscal year in the indicated positions.

Transaction Code Search Pop-up Field Instructions

The Transaction Code Search pop-up (Figure 29 ) appears when you click  on
the Transaction Code List window (Figure 28 ). This pop-up is used to search for a

Optional, alphanumeric, 35 positions max.

Conditional, alphanumeric, 27 positions max.

Conditional, alphanumeric, 35 positions max.

Required, numeric, 27 positions max.

Required, numeric, 27 positions max.
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TC on the TC table. For instructions on using the Transaction Code Search
pop-up, see Searching For A Transaction Code .

TC
Type the 2-digit TC. A TC is used to record hours worked, absences,
allowances/differential entitlements, and other entitlements. A complete list of
TC’s can be found in TMGT Table 032, Transaction Codes, or in Title I,
Chapter 7, Section 1.

Transaction Code List Window Field Instructions

The Transaction Code List window (Figure 28 ) is displayed when you select
Tables > Transaction Code  from the STAR Menu Bar. This window displays a
Transaction Code (TC) table used by Timekeepers when preparing T&A’s. TC’s
can be enabled or disabled, as needed by the agency. If a new TC is added, the
Application Administrator will receive instructions on how to add the new TC.
For more information on the Transaction Code List window, see Adding Or
Updating A Transaction Code .

Transaction
Code List Box

This field is system generated and displays a list of TC’s available to the agency.
These TC’s are found in TMGT, Table 032, Transaction Code.

Detail

Prefix
Type the 2-digit prefix, if applicable. The TC prefix is a code used to record the
percentage rate for environmental differential pay and danger pay and to expand
the definition for certain TC’s or to create a new TC and definition when the TC
has been previously used without a prefix. For more information on prefixes, see
Title I, Chapter 7, Section 1, Time And Attendance Instructions.

Trans Code
Type the 2-digit TC. A TC is used to record hours worked, absences,
allowances/differential entitlements, and other entitlements. A complete list of
TC’s can be found in TMGT Table 032, Transaction Codes, and in Title I,
Chapter 7, Section 1, Time And Attendance Instructions.

Suffix
Type the 1-digit suffix, if applicable. The transaction suffix is used to record
differential, union representation, and to supplement certain TC’s to vary their
meaning. For more information on suffixes, see Title I, Chapter 7, Section 1,
Time And Attendance Instructions.

Note:  Employees who perform work on a Sunday holiday (or a Sunday in-lieu of
holiday) are entitled to holiday pay, as well as Sunday differential.

Description
Type the TC description.

Required, numeric, 2 positions

No entry

∇

Conditional, numeric, 2 positions max.

Required, numeric, 2 positions max.

Conditional, numeric, 2 positions max.

Required, alphanumeric, 49 positions max.
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Short
Description

Type the short description of the TC. This description displays on the Transaction
Code Selection List pop-up (Figure 43 ). Descriptions from the Transaction Code
Selection List pop-up are displayed in the list box on the Biweekly T&A
window (Figure 41 ).

Leave Type

Click  to display the Leave Type List window (Figure 31 ). Click  to return
to the Transaction Code List window (Figure 28 ). This option is used when a new
leave TC is being added to the Payroll/Personnel System.

Max PP:
This field is used to record pay period limitation amounts. Type the number of
whole hours (or days) in the first four positions. If fractions must be recorded, see
the Fractions Of Hours Table .

Type TC
Click ][  to display the type of TC. For a list of the valid values, see TC Type
Table .

Enabled
Click ][  to choose Y or N to mark the TC as enabled or disabled. Only those
TC’s marked enabled will be visible to the timekeeper.

Accrue Flag
Click ][  to choose Y or N to indicate whether or not this TC is included in the
leave accrual calculation.

Top Flag
Click ][  to choose Y or N to indicate if this TC requires accounting.

Pay Period List Window Field Instructions

The Pay Period List window (Figure 30 ) is displayed when you select
Tables > Pay Period  from the STAR Menu Bar. The Pay Period List window is a
read-only window. The Pay Period List window displays the previous year’s pay
periods, the current year’s pay periods, and the future year’s pay periods. STAR
provides a Generate Pay Periods  option to generate additional pay periods. For
more information on the Pay Period List window, see Pay Period .

Pay Period List
Box

This field is system generated and displays a list of pay periods and
ccorresponding beginning and ending dates.

Required, alphanumeric, 25 positions max.

Conditional, alpha

Conditional, numeric, 4 positions max., 2 fraction positions

Required

Required, alpha, 1 position

Required, alpha, 1 position

Optional, alpha, 1 position

No entry
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Leave Type Search Pop-up Field Instructions

The Leave Type Search pop-up (Figure 32 ) appears when you click  on the
Leave Type List window (Figure 31 ). This pop-up is used to search for a leave
type on the table. For instructions on using the Leave Type Search pop-up, see
Searching For A Leave Type On The Table .

Type
Type the 4-character leave type abbreviation. If you enter data into this field,
leave the description field blank.

OR

Description
Type the leave type description. If you enter data into this field, leave the Type
field blank.

Leave Type List Window Field Instructions

The Leave Type List window (Figure 31 ) is displayed when you select Tables >
Leave Type  from the STAR Menu Bar. The Leave Type List window displays the
leave types used by Timekeepers when preparing T&A’s. For more information
on the Leave Type List window, see Adding A Leave Type To The Leave Type
Table .

Leave Type List
Box

This field is system generated and displays a list of leave types.

Detail

Type
Type the 4-character abbreviation of the leave type.

Description
Type the description of the leave type.

Long Name
Type the long name of the leave type.

Max Balance
Type the maximum hours balance for the leave type. Type the number of whole
hours in the first four positions. If fractions must be recorded, see the Fractions
Of Hours Table .

Init Forward
Type the leave balance brought forward for the leave type. Type the number of
whole hours in the first four positions. If fractions must be recorded, see the
Fractions Of Hours Table .

Conditional, alpha, 4 positions

Conditional, alpha, 35 positions max.

No entry

∇

Required, alpha, 4 positions

Required, alpha, 35 positions max.

Required, alpha, 20 positions max.

Required, numeric, 5 positions max.

Required, numeric, 6 positions max.
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Accrued
Type T (true) to indicate that this is an accrued leave type or F (false) to indicate
that this leave type is not accrued. This field indicates whether or not this leave
type is an accrued leave type.

Earned Used
Either type Y (yes) to indicate that this leave type does subtract time from the
balance or N (no) to indicate that this leave type adds time to the balance. This
field indicates whether or not this leave type adds time used to the balance rather
than subtracting from it.

Data Type
Click ][  to select the data type. For a list of data types, see the Data Type Table .

Required, alpha, 1 position

Required, alpha, 1 position

Required, alpha, 1 position
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Field Instructions for Employee Maintenance

Contact Point List Window Field Instructions

Employee List Window Field Instructions

Employee Search Pop-up Field Instructions

Employee Window Field Instructions

New Employee Pay Period Selection Pop-up Field Instructions

Employee Leave Account Window Field Instructions

Print Window Field Instructions

Contact Point List Window Field Instructions

The Contact Point List window (Figure 33 ) is displayed when you select File >
Employee Maintenance , File > Time And Attendance Maintenance , File >
Transmit , or File > Print Reports  if a Timekeeper has access to more than one
contact point. This window is used to designate the applicable contact point for a
Timekeeper.

List Box
A list of available contact points for a Timekeeper is displayed in this box. Select
the desired contact point and click the applicable tool button.

Employee List Window Field Instructions

The Employee List window (Figure 34 ) is displayed when you select
File > Employee Maintenance  or File > T&A Maintenance  from the STAR Menu
Bar. The Employee List window displays a list of employees for a contact point.

Employee List
This field is system generated and displays a list of the employees for a contact
point.

Employee Search Pop-up Field Instructions

The Employee Search pop-up (Figure 35 ) appears when you click  on the
Employee List window (Figure 34 ). This pop-up is used to search for an
employee on the Employee List window (Figure 34 ). For instructions on using
the Employee Search pop-up (Figure 35 ), see Searching For An Employee .

Required

No entry
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Last Name
Type the employee’s complete or partial last name.

SSN
Type the employee’s complete SSN.

Note:  You can type a % (percent sign) in either field to display a list of all
employees for that Timekeeper.

Employee Window Field Instructions

The Employee window (Figure 36 ) is used by the Timekeeper to add/update

employee records. The Employee window is displayed by clicking  on the
Employee List window (Figure 34 ). For instructions on adding/updating
employee records, see Adding Or Updating An Employee Record .

SSN
Type the employee’s 9-digit SSN.

Last Name
Type the employee’s last name.

First
Type the employee’s first name.

Middle
Type the employee’s middle name.

Work Schedule
Click ][  to select the employee’s work schedule. For definitions of the valid
values, see the Work Schedule Table .

Pay Plan
Click ][  to select the employee’s pay plan. For definitions of the valid values,
see the Pay Plan Table .

Tour of Duty
Type the number of hours in the employee’s tour of duty. Type the number of
hours in the first 4 positions, and if fractions are necessary, type a “. ” and the
fraction in the last 2 positions. For definitions of the valid fraction values, see the
Fractions Of Hours Table .

Special Type
Click ][  to select the employee’s special employment type code. For definitions
of the valid values, see the Special Type Table .

Leave Information

Annual Leave
Category

Click ][  to select the employee’s annual leave category. This field defaults to 4.
For definitions of the valid values, the Annual Leave Category Table .

Conditional, alpha, 17 positions max.

Conditional, numeric, 9 positions

Required, numeric, 9 positions

Required, alphanumeric, 17 positions max.

Required, alphanumeric, 12 positions max.

Optional, alphanumeric, 12 positions max.

Required

Required, alpha, 2 positions

Required, numeric, 6 positions max.

Conditional, alpha

∇

Required, numeric, 1 position
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Sick Leave
Category

Click ][  to select the employee’s sick leave category. This field defaults to 4.
For definitions of the valid values, see the Sick Leave Category Table .

Annual Leave
Ceiling

Type the number of hours for the employee’s annual leave ceiling. This field
defaults to 240 .

Day Limitation
Click this field if the employee is on a day limitation tour of duty. A check mark
appears in this box.

Contact Point

Agency
The employee’s 2-character agency code is displayed in this field. A list of
agency codes is displayed in TMGT, Table 023, Agency/Bureau. This field
defaults to the agency code for the contact point in which the Timekeeper is
working.

State
The employee’s 2-digit state code is displayed in this field. A list of state codes is
displayed in TMGT, Table 016, Geographical Location Codes With Names. This
field defaults to the state code for the contact point in which the Timekeeper is
working.

Town
The employee’s 4-digit town code is displayed in this field. A list of town codes
is displayed in TMGT, Table 016, Geographical Location Codes With Name. This
field defaults to the town code for the contact point in which the Timekeeper is
working.

Unit
The employee’s 2-digit agency-assigned unit code is displayed in this field. The
unit code is assigned by the agency to identify each contact point within a town.
This field defaults to the unit code for the contact point in which the Timekeeper
is working.

Timekeeper Code
The employee’s 2-digit agency-assigned timekeeper code is displayed in this
field. This field defaults to the timekeeper code for the contact point in which the
Timekeeper is working.

New Employee Pay Period Selection List Pop-up Description

The New Employee Pay Period Selection List pop-up (Figure 37 ) appears when
you close the Employee window (Figure 36 ) after adding an employee. This
pop-up is used to select the first pay period for which you wish to prepare a T&A

Required, numeric, 1 position

Required, numeric, 3 positions

Optional

∇

No entry

No entry

No entry

No entry

No entry



Title I, Chapter 7, Section 3
System For Time And Attendance Reporting (STAR)

94 Updated 9/12/03

for a new employee. For more information on the New Employee Pay Period
Selection pop-up, see Adding Or Updating An Employee Record .

Employee Leave Account Window Field Instructions

The Employee Leave Account window (Figure 38 ) is displayed when you select

an employee and click  from the Employee List window (Figure 34 ). The
Employee Leave Account window is used to maintain an employee’s leave
information. For instructions on using the Employee Leave Account window, see
Adding Or Updating A Leave Type Record .

Employee

SSN
This field is system generated from the employee’s detail record. The employee’s
9-digit SSN is displayed in this field.

Name
This field is system generated from the employee’s detail record. The employee’s
name is displayed in this field.

Pay Period
This field is system generated. The pay period is displayed in this field.

Begin Date
This field is system generated. The beginning date of the pay period is displayed
in this field.

List Box
This field is system generated based on the information entered by the timekeeper
in the detail area. The leave type, amount brought forward, amount accrued,
amount used, and the balance to date are displayed in this field.

Detail

Type
The first part of this field is system generated from the selection made in the
second part of the field. A 4-character abbreviation of the leave type is displayed
in the first part of the field. To display the list of leave types, click ][ . For a list
of the valid values, see Leave Type Table .

Forward
Type the number of whole hours in the first four positions. If fractions must be
recorded, type a “. ” (period) and the fraction in the last two positions. For a list
of the valid values, see Fractions Of Hours Table . The system defaults to 0 if no
entry is made in this field.

Note:  When recording leave earned from a Time Off Award, leave used is
subtracted from the Forward balance, not added.

∇

No entry

No entry

No entry

No entry

No entry

∇

Required, alpha, 4 positions

Conditional, numeric, 7 positions
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Accrued
This field is system generated. This field displays the employee’s accrued leave
category and is generated from the employee’s detail record.

Used
This field is system generated. This field is system generated for all leave types
except regular military leave. For a list of the valid values, see Fractions Of

Hours Table . The system defaults to 0 if no entry is made in this field.

Part Time
Information

Part-Time
Unapplied Sick

Type the number of unapplied hours in this field. Type the number of whole hours
in the first 4 positions. If fractions must be recorded, type a “. ” (period) and the
fraction in the last two positions. Part-time employees earn 1 hour of sick leave
for each 20 hours worked. All hours worked in excess of the basic work
requirement of a part-time employee, including overtime, are counted in
determining the biweekly accrual of sick leave, up to a maximum of 80 hours in a
pay status per pay period. Divide the total number of hours worked by 20. If the
result is not evenly divisible, the remainder is called unapplied hours and is
carried forward to use in the computing leave earned for the next pay period.

Part-Time
Unapplied
Annual

Type the number of whole hours in the first 4 positions. If fractions must be used,
type a “. ” (period) and the fraction in the last two positions. Type the number of
unapplied hours in this field. Part-time employees earn annual leave on pro rata
basis depending on the leave category and the number of hours worked.
Employees in Leave Category 4 earn 1 hour for each 20 hours worked: Leave
Category 6, 1 hour for each 13 hours worked; Leave Category 8, 1 hour for each
10 hours worked. All hours worked in excess of the basic work requirement for a
part-time employee, including overtime, are counted in determining the biweekly
accrual of annual leave, up to a maximum of 80 hours in pay status per pay
period. Divide the total number of hours worked by the minimum hour
requirement (i.e., 10, 13, or 20). If the result is not evenly divisible, the remainder
is called unapplied hours and is carried forward to use in computing leave earned
for the next pay period.

Note:  When using TC65, Regular Military Leave, the number of days of military
leave used is entered into the Used field. Time recorded using TC65 creates a
positive balance that accumulates the military leave used. Use of any amount of
military leave during a workday constitutes the use of that day toward the 15-day
limitation.

No entry

Conditional, numeric, 7 positions

∇

Conditional, numeric, 6 positions max.

Conditional, numeric, 6 positions max.
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Print Window Field Instructions

The Print window (Figure 39 ) is displayed when you click  on an open
window. The Print window is used to make a screen print of the open window.
For instructions on using the Print window, see Printing The Open Window .

Printer

Name
Click ][  to display the available printers. Select the applicable printer.

Status
This field is system generated. It displays the status of the print job.

Type
This field is system generated. It displays the type of printer to be used.

Where
This field is system generated. It indicates that this is the location at which the
data is printed.

Comment
This field is system generated. It displays comments regarding the print job.

Print Range
This field is system generated. This field defaults to All .

Copies

Number of
Copies

Click ][  to select the number of copies to be printed. This field defaults to one.

Collate
Click this field if you have chosen to print multiple copies, and you would like
these copies collated. A check mark appears in this field.

∇

Required

No entry

No entry

No entry

No entry

No entry

∇

Required, numeric, 4 positions max.

Conditional
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Field Instructions for T&A Maintenance

Time And Attendance List Window Field Instructions

Biweekly T&A Window Field Instructions

Transaction Code Selection List Pop-up Field Instructions

Transaction Code Selection List Search Pop-up Field Instructions

Accounting Code Selection List Pop-up Field Instructions

Accounting Code Selection List Search Pop-up Field Instructions

Enter Total Dollar Amount Pop-up Field Instructions

Update Header Pop-up Field Instructions

Split T&A Information Pop-up Field Instructions

Rollover Pop-up Field Instructions

Pay Period List Pop-up Field Instructions

Prepare Transmit File Window Field Instructions

Transmit Password Pop-up Field Instructions

Save Transmit File As Pop-up Field Instructions

Print Reports Window Field Instructions

Time And Attendance List Window Field Instructions

The Time and Attendance List window (Figure 40 ) is displayed when you select
an employee on the Employee List window (Figure 34 ) and click [T&A List] . The
Time and Attendance List window provides a list, by pay period, for all T&A’s
currently on the database for the employee and a status of each. For more
information on the Time And Attendance List window, see About T&A
Maintenance .

Employee

SSN
This field is system generated based on the employee selected on the Employee
List window. The employee’s 9-digit SSN is displayed in this field.

Name
This field is system generated based on the employee selected on the Employee
List window. The employee’s name is displayed in this field.

Employee List
This field is system generated. A list of T&A’s, by pay period, for an employee is
displayed in this field.

∇

No entry

No entry

No entry
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Biweekly T&A Window Field Instructions

The Biweekly T&A window (Figure 41 ) is displayed when you select an

employee and click  on the Employee List window (Figure 34 ). The Biweekly
T&A window is used to prepare an employee’s T&A. Timekeepers can enter a
T&A at any time during the pay period rather than having to wait until the end of
the pay period. For instructions on using the Biweekly T&A window, see
Preparing A T&A .

Employee

SSN
This field is system generated from the employee’s detail record or can be typed

to find a T&A for an SSN. Type the SSN of the employee and click . The
employee’s 9-digit SSN is displayed in this field.

Name
This field is system generated from the employee’s detail record. The employee’s
name is displayed in this field.

AWS
This field is system generated from the employee’s header record. This field
displays the type of work schedule the employee is working.

Pay Period

Pay Period
This field is system generated. The current pay period and the date are displayed
in this field, but you can click ][  to view data for other pay periods.

Begin Date
This field is system generated based on the pay period displayed in the Number
field. The begin date of the pay period is displayed in this field.

End Date
This field is system generated based on the pay period displayed in the Number
field. The end date of the pay period is displayed in this field.

Split #
This field is system generated. If the T&A is a split T&A, the part number is
displayed in this field. If the T&A is not a split T&A, the default is 0.

Note:  If a user wishes to to merge the 2 parts of a split T&A, he/she must select
one part of the split on the Time And Attendance List window (Figure 40 ) and
click [Merge] . This field will reset to 0 when a split T&A is merged.

Status
This field is system generated. The status of the T&A is displayed in this field.
For a list of valid values and definitions of these values, see Status Table .

∇

Conditional, numeric, 9 positions

No entry

No entry

∇

Conditional, numeric, 2 positions

No entry

No entry

No entry

No entry
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List Box
This field is system generated, based on the information entered by the
Timekeeper in the detail area.

Detail

Prefix
Type the 2-digit prefix, if applicable. The TC prefix is a code used to record the
percentage rate for environmental differential pay and danger pay and to expand
the definition for certain TC’s or create a new TC and definition when the TC has
been previously used without a prefix. For more information about prefixes, see
Title I, Chapter 7, Section 1, Time And Attendance Instructions.

TC
Type the 2-digit TC. A TC is used to record hours worked, absences,
allowances/differential entitlements, and other entitlements. A complete list of
TC’s can be found in TMGT Table 032, Transaction Codes, and on the STAR
Transaction Code Table. For specific TC entry instructions, see Title I, Chapter 7,
Section 1.

Note:  When entering monetary TC’s, (Figure 28 ) check the Type TC field on the
Transaction Code List window. For definitions of the TC types, see the TC Type
Table .

Suffix
The transaction suffix is used to record differential, union representation, and to
supplement certain TC’s to vary their meaning. For more information on suffixes,
see Title I, Chapter 7, Section 1, Time And Attendance Instructions.

Note:  Employees who perform work on a Sunday holiday (or a Sunday in-lieu of
holiday) are entitled to holiday pay, as well as Sunday differential.

Note:  You can click  to display a list of all prefixes, TC’s, and suffixes. When

you click , a Transaction Code Selection List pop-up (Figure 43 ) appears.
Select the applicable TC and click [Select]  to select the TC or click [Cancel]  to
cancel the function and return to the Biweekly T&A window (Figure 41 ). For
more information on the Transaction Code Selection List pop-up, see Using The
Transaction Code Selection List Pop-up .

Week 1 Hrs
Type the number of whole hours in the first 4 positions. If fractions must be
present, type a “. ” (period) and the fraction in the last 2 positions. This field is
used to record hours in pay status and monetary amounts for allowances,
differentials, and deductions and hours in nonpay status for the first week of the
pay period. The system defaults to 00 if no entry is made. For a list of the valid
fraction values, see Fractions Of Hours Table .

Week 2 Hrs
Type the number of whole hours in the first 4 positions. If fractions must be
present, type a “. ” (period) and the fraction in the last 2 positions. This field is
used to record hours in pay status and monetary amounts for allowances,
differentials, and deductions and hours in nonpay status for the second week of

No entry

∇

Conditional, numeric, 2 positions

Required, numeric, 2 positions

Conditional, numeric, 1 position

Conditional, numeric, 5 positions

Conditional, numeric, 5 positions
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the pay period. The system defaults to 00  if no entry is made. For a list of the
valid fraction values, see Fractions Of Hours Table .

Accounting

Click  to select the applicable accounting code if the Accounting Table has
been established. The Accounting Code Selection List pop-up (Figure 44 )
appears. On the Accounting Code Selection List pop-up, select the applicable
accounting code and click [Select]  to select the accounting code or [Cancel]  to
cancel the function and return to the Biweekly T and A window (Figure 41 ). The
accounting codes on the Accounting Code Selection List pop-up are the same
accounting codes listed on the Accounting Code List table. This code is used to
disburse and obligate the employee’s pay and related expenditures to the proper
accounting records. To duplicate the accounting code entry from the previous line
in its entirety, type the /  (slash) key. By entering / , the last line entered is
repeated. For more information on the Accounting Code Selection List pop-up,
see Using The Accounting Code Selection List Pop-up .

Note:  If an agency uses stored accounting, the first time a Timekeeper prepares a
T&A for an employee, the Accounting Data Usage Code on the employee’s
header record should be a 1 for stored accounting on the first line with accounting
entered on the first TC line on the employee’s T&A. The following pay period,
the Accounting Data Usage Code should be a 2 to use stored accounting.

Transaction Code Selection List Pop-up Field Instructions

The Transaction Code Selection List pop-up (Figure 43 ) appears when you

click  on the Biweekly T&A window (Figure 41 ). The Transaction Code
Selection List pop-up is used to select TC’s to appear on the T&A. For more
information on the Transaction Code Selection List pop-up, see Preparing A T&A .

TC List Box
This field is system generated. A list of TC’s available to the individual
Timekeeper are displayed in this box. Select the applicable TC.

Note:  When using TC65, Regular Military Leave, the number of days of military
leave used is entered on the employee’s leave account, rather than the number of
hours. Time recorded using TC65 creates a positive balance that accumulates the
military leave used. Use of any amount of military leave during a workday
constitutes the use of that day toward the 15-day limitation. Count only regularly
scheduled workdays as beginning and ending dates of regular military leave. Do
not count nonworkdays falling at the beginning or end of the military leave even
if the military orders include these days. Only nonwork days falling between
periods of regularly scheduled work days are to be counted if the military orders
so specify. On the T&A, in the detail area, the Timekeeper enters the military
leave with the number of hours the employee should be paid.

Condiitional, alphanumeric, 27 positions

No entry
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Transaction Code Selection List Search Pop-up Field Instructions

The Transaction Code Selection List Search pop-up (Figure 45 ) appears when you
select Edit > Search  on the Transaction Code Selection List pop-up. This pop-up
is used to search for a TC on the Transaction Code Selection List pop-up. For
more information on this pop-up, see Using The Transaction Code Selection List
Pop-up .

Prefix
Type the 2-digit numeric TC prefix.

TC
Type the 2-digit TC.

Suffix
Type the 1-digit TC suffix.

Short
Description

Type the short description of the TC.

Leave Type
Type the 4-position leave type abbreviation.

Accounting Code Selection List Pop-up Field Instructions

The Accounting Code Selection List pop-up (Figure 44 ) appears when you

click  on the Biweekly T&A window (Figure 41 ). The Accounting Code
Selection pop-up is used to select accounting codes applicable to the TC’s on the
T&A. For more information on the Accounting Code Selection List pop-up, see
Preparing A T&A .

Accounting
Codes

This field is system generated. A list of accounting codes available to the
individual Timekeeper is displayed in this box if the accounting code table has
been established. Select the applicable accounting code.

Accounting Code Selection List Search Pop-up Field Instructions

The Accounting Code Selection List Search pop-up (Figure 46 ) appears when you
select Edit > Search  on the Accounting Code Selection pop-up. This pop-up is
used to search for an accounting code on the Accounting Code Selection List

Optional, numeric, 2 positions

Required, numeric, 2 positions

Optional, numeric, 1 position

Optional, alphanumeric, 25 positions max.

Optional, alpha, 4 positions

No entry
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pop-up. For more information on the Accounting Code Selection List Search
pop-up, see Using The Accounting Code Selection List Pop-up .

Category
Type the category of the accounting code for which you are searching.

Description
Type the description of the accounting code for which you are searching.

Enter Total Dollar Amount Pop-up Field Instructions

The Enter Total Dollar Amount pop-up (Figure 42 ) appears when you enter a
dollar amount TC in the Prefix, TC, and Suffix fields on the Biweekly T&A
window. This TC is used to enter an amount in dollars and cents. Enter the total
dollars and cents for the TC. Click [OK] and the Week 1 and Week 2 hours fields
will be updated following the procedures described in Title I, Chapter 7,
Section 1, Time and Attendance Instructions. For more information on using the
Enter Total Dollar Amount pop-up, see Using The Enter Total Dollar Amount
Pop-up .

Dollar Amount
Type the total dollar amount in dollars and cents for the appropriate TC.

Update Header Pop-up Field Instructions

The Update Header pop-up (Figure 47 ) appears when you click  on the
Biweekly T&A window. The Update Header pop-up contains all of an employee’s
T&A header information for the pay period. For instructions on the Update
Header pop-up, see Maintaining A Header Record .

Pay Period

Number
This field is system generated based on the selection made on the Time And
Attendance List window (Figure 40 ). The pay period number is displayed in this
field.

Begin Date
This field is system generated. The beginning date of the pay period is displayed
in this field.

Corrected
Record

This field is system generated when [Correct T&A]  is selected on the Time And
Attendance List window (Figure 40 ) and indicates a corrected T&A. A check

Optional, alphanumeric, 27 positions max.

Optional, alphanumeric, 35 positions max.

Required, numeric, 6 positions max.

∇

No entry

No entry

No entry
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mark will appear in the first part of this field if this is a corrected T&A. The
record number is displayed in the second part of this field.

Split/Part
This field is system generated and indicates a split T&A. A check mark will
appear in the first part of this field if this is a split T&A. The part number is
displayed in the second part of this field. Valid values are 1 or 2.

Status
This field is system generated. It displays the status of the T&A. For a list of the
valid values and definitions of the values, see Status Table .

Detail

New Employee
Click this field if the employee is a new employee. A check mark appears in this
field to indicate a new employee.

Final T&A
Click ][  to indicate if this is the final T&A for an employee. Valid values for
non-Department of Justice employees are Not Final T/A  and Final
T/A . Valid values for Department of Justice are:

• Not Final T/A

• Final T/A

• 1st Week FLSA

• 1st Wk + Final

• 2nd Week FLSA

• 2nd Wk + Final

• Bothweek FLSA

•  Both Wk + Final

Begin

Day
Click ][  to select the begin day of the pay period for the employee. This field is
used for a new employee. If data is entered into this field, the date field is system
generated. Valid values are 1-14 .

Date
Type the beginning date for a new employee. If data is entered into this field, the
day field is system generated. The date is in the XX/XX/XXXX  format.

End

Day
Click ][  to select the end day in pay status of the pay period for a separating
employee. This field is used for an employee with a final T&A. If data is entered
into this field, the date field is system generated.

No entry

No entry

∇

Conditional, 1 position

Conditional

∇

Conditional, numeric, 2 positions

Conditional, numeric, 8 positions

∇

Conditional, numeric, 2 positions
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Date
Type the last date in pay status for a separating employee. If data is entered into
this field, the day field is system generated. The date is in the XX/XX/XXXX
format.

AWS
Click ][  to select the alternate work schedule (AWS) options. For a list of the
valid values, see AWS Table . This field defaults to Normal Schedule .

Days Worked
Click ][  to select the number of days worked by the employee. Valid values are
00-14 .

Advance Leave
Click ][  if the employee has been granted advanced leave. For a list of the valid
values, see Advance Leave Table .

Wage Shift
FEGLI

Click ][  if the employee is eligible for FEGLI wage shift. If the employee is
coded as General Schedule employee, the valid values are:

• blank

• Normal T&A

• Exceed Biweek

If the employee is coded as Wage Grade employee, the valid values are:

• First Shift

• Second Shift

• Third Shift

• Varied Shift

Standby/AUO/Avail
Pay

Flag
Click this field if the employee is eligible for standby/AUO hours.
Standby/AUO hours are hours and pay differential entitlements for employees
who receive premium pay on an annual basis for administratively uncontrollable
overtime or regularly scheduled standby duty.

First (1st) Week
Type the number of standby/AUO hours authorized for the first week of the pay
period. Valid values are 01-40 .

Second (2nd)
Week

Type the number of standby/AUO hours authorized for the second week of the
pay period. Valid values are 01-40 .

Conditional, numeric, 8 positions

Required, numeric, 1 positiion

Conditional, numeric, 2 positions

Conditional

Conditional, alpha

∇

Conditional

Conditional, numeric, 2 positions

Conditional, numeric, 2 positions
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Percent (%)
Premium

Click ][  to display the percentage of pay differential entitlements that will be
used to compute the employee’s pay for Standby/AUO worked. Valid values are
02 , 05 , 07 , 10 , 12  , 15 , 17 , 20 , 22 , 25 , or 99 .

NFC Use
Click ][  to display the type of employee. For a list of the valid values, see Type
Of Employment Table (NFC Use) .

Accounting Data
Usage Code

Click ][  to indicate whether or not to use stored accounting. For a list of the
valid values, see Accounting Data Usage Code Table . The system defaults for
adding accounting on each line of the T&A.

Note:  Accounting cannot be stored on a corrected T&A.

Stored
Accounting

This field is system generated. If the agency uses stored accounting, the stored
accounting is displayed in this field.

Note:  If a 2 is displayed, stored accounting is being used. If stored accounting
was being used when the data conversion from PC-TARE to STAR took place,
the stored accounting will not be displayed in this field; however, it will be used
by STAR. To display the stored accounting from PC-TARE in STAR, you must
enter a 1 in the Accounting Data Usage Code in STAR once.

Remarks
Use this field to enter any remarks by the timekeeper. These remarks appear on
the T&A; however, only the first 23 positions are to transmitted to NFC.

Split T&A Information Pop-up Field Instructions

A Confirm Split pop-up (Figure 48 ) appears when you click [Split Selected T&A]
on the Time And Attendance List window (Figure 40 ). The Split T&A
Information pop-up (Figure 49 ) appears when you click [Yes]  on the Confirm
Split pop-up. This pop-up is used to split a T&A that has not been transmitted.
For instructions on using the Split T&A Information pop-up, see Preparing A
Split T&A . Split T&A’s are prepared when certain actions occur on any day of the
pay period except for the second day or the last day of the pay period or if the
employee worked on the day of the change. For a list of occurrences when a split
T&A may be prepared, see Split T&A Table .

Note:  The situations in this table are examples of when the preparation of a split
T&A may be required; however, a split T&A is not always necessary for each of
these situations.

Conditional, numeric, 2 positions

Conditional, alpha, 2 positions

Required, numeric, 1 position

No entry

Optional, alphanumeric, 254 positions max.
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Split Part 1 Begin
Day

Type the day of the pay period to begin the first part of the split T&A. This field
defaults to 1.

Split Part 1 End
Day

Type the day of the pay period to end the first part of the split T&A. Valid values
are 01-13 .

Split Part 2 Begin
Day

Type the day of the pay period to begin the second part of the split T&A. Valid
values are 02-14 .

Split Part 2 End
Day

Type the day of the pay period to end the second part of the split T&A. This field
defaults to 14 .

Note:  Leave data is recorded only on the second T&A. Also, if you use TC 65,
Regular Military Leave, when preparing a split T&A, you must record the
number of days of military leave used on the Employee Leave Account window
(Figure 38 ). If you fail to do this, a message will appear reminding you to do this.

Rollover Pop-up Description

The Rollover pop-up (Figure 50 ) appears when you select Edit > Rollover Pay
Period  on the Employee List window (Figure 34 ). The Rollover pop-up is used to
create a new pay period for all employee records on the Employee List that were
successfully transmitted the previous pay period. For more information on the
Rollover pop-up, see Rolling Over T&A’s .

Pay Period List Pop-up Field Instructions

The Pay Period List pop-up (Figure 51 ) appears when you click [Yes]  on the
Rollover pop-up. The Pay Period List pop-up is used to select a pay period to roll
over T&A’s. For more information on the Pay Period List pop-up, see Rolling
Over T&A’s .

Prepare Transmit File Window Field Instructions

The Prepare Transmit File window (Figure 52 ) is displayed when you select

File > Transmit  from the STAR Menu Bar or click  on the Biweekly T&A

Required, numeric, 2 positions max.

Required, numeric, 2 positions max.

Required, numeric, 2 positions max.

Required, numeric, 2 positions max.
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window (Figure 41 ). The Prepare Transmit File window is used to prepare a
transmission file to be sent to NFC for processing. For instructions on using the
Prepare Transmit File window, see Transmitting T&A’s .

Use JCL
Click this field if you do not want to use the JCL. A check mark appears in this
box indicating that you want to use the JCL. The default is the box checked. In
order to use JCL, you must first establish JCL in the JCL option.

Xmit Status

Preparing
Transmit For Pay
Period

This field is system generated. The pay period for the T&A being transmitted is
displayed in this field.

For SSN:
This field is system generated. As each employee’s T&A record is being copied
to the transmit file, his/her SSN appears in this field.

Verified Only
Click this box to prepare a transmission file for only those T&A’s that have a
verified status.

List Box
This field is system generated. The SSN, last name, first name, middle name, and
the status of the T&A are displayed in this box. Each line represents an individual
employee. You can select an individual employee or a group of employees for
whom you are creating the transmission file.

Total Xmit T&A’s

There Are
This field is system generated. The number of T&A’s transmitted is displayed in
this field. As T&A’s are transmitted, this field is updated.

T&A’s To Be
Xmit’d; In

This field is system generated. As each T&A is transmitted, this field increases by
a multiple of 12.

Transmit Password Pop-up Field Instructions

If you use JCL and the Don’t Transmit User ID/Password check box has not been
selected on the Build JCL window, the Transmit Password pop-up (Figure 53 )
appears when you click [Xmit Selected]  or [Xmit All]  on the Prepare Transmission
File window (Figure 52 ). The Transmit Password pop-up (Figure 53 ) is used to
enter a Transmitter’s user ID and password before preparing a transmission file.

Conditional

∇

No entry

No entry

Conditional

No entry

∇

No entry

No entry
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For instructions on using the Transmission Password pop-up, see Transmitting
T&A’s .

User ID
Type your User ID for the NFC Mainframe.

Password For
NFC’s Mainframe

Type your password for the NFC Mainframe. Your password is not displayed on
the screen.

Note:  If you deleted the User ID and password lines from the JCL.txt file, you
should type X’s in both fields on this pop-up. For more information on the
JCL.txt file, see Building JCL .

New Password 
Type the new password you want for the NFC mainframe. Your password is not
displayed on the screen. Your NFC mainframe password will be changed to the
value entered, and this will be the password entered in the Password For NFC’s
Mainframe field on subsequent transmissions.

Save Transmit File As Pop-up Field Instructions

The Save Transmit File As pop-up (Figure 54 ) appears when you click [OK]  on
the Transmit Password pop-up (Figure 35 ). The Save Transmit File As pop-up is
used to define where to save the transmit file to. For more information on the
Save Transmit File As pop-up, see Transmitting T&A’s .

Look In
Click ][  to locate where you want to save the transmission file.

List Box
This field is system generated. A list of files is displayed in this field.

File Name
Type the file name of the transmission file you are saving.

Save As Type
Click ][  to indicate the type of file you are saving.

Open As Read
Only

Click this field to open the file as read only. A check mark appears in this box.

Print Reports Window Field Instructions

The Print Reports window (Figure 55 ) is displayed when you select File > Print
Reports  from the STAR Menu Bar. This window is used to print an employee’s
T&A. For instructions on the Print Reports window, see Printing T&A’s .

Required, alphanumeric, 6-8 positions

Required, alphanumeric, 6-8 positions

Optional, alphanumeric, 6-8 positions

Required

No entry

Required, alphanumeric

Required

Required, 1 position
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Report Preference

T and A
Click this field to print the T&A data in T&A format.

Text
Click this to print the T&A in text format.

Note:  STAR defaults to T&A.

Print Status

Printing Pay
Period

This field is system generated. The pay period for which the T&A is being
printed is displayed in this field.

For SSN
This field is system generated. The SSN of the employee whose T&A is currently
being printed is displayed in this field.

Verified Only
Click this box to print only those T&A’s that have a verified status.

List Box
This field is system generated. A list of employees whose T&A’s are to be printed
and a status of each T&A is displayed in this field.

Status Counts

New
This field is system generated.

In Progress
This field is system generated. The number of in progress T&A’s is displayed in
this field.

Error
This field is system generated. The number of T&A’s in error is displayed in this
field.

Verified
This field is system generated. The number of verified T&A’s is displayed in this
field.

Xmit
This field is system generated. The number of transmitted T&A’s is displayed in
this field.

Print Stored
Accounting

Click this field if you want to remove the check mark and do not wish to print
stored accounting. If you are using stored accounting and wish to print the stored
accounting, leave this field checked. The default is this field checked.

∇

Optional, 1 position

Optional, 1 position

∇

No entry

No entry

Conditional

No entry

∇

No entry

No entry

No entry

No entry

No entry

Optional
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Reference Tables

This section presents the following reference tables:

Test/Prod Table

Fractions Of Hours Table

TC Type Table

Data Type Table

Backup Options Table

Select T&A Restore Type Table

Select Table Restore Type Table

Work Schedule Table

Pay Plan Table

Special Type Table

Annual Leave Category Table

Sick Leave Category Table

Leave Type Table

Status Table

AWS Table

Advance Leave Table

Type Of Employment Table (NFC Use)

Accounting Data Usage Code Table

Split T&A Table

Report Preference Table

Test/Prod Table

PROD Production. Transmitted T&A’s are processed through production files by
NFC.

TEST Test file. Transmitted T&A’s are not processed through production files by
NFC.

Fractions Of Hours Table

Blank No Fraction

25 1/4 Hour

50 1/2 Hour

75 3/4 Hour
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TC Type Table

$ Monetary (amounts not to exceed $99.99 are entered in
Week 1 and are continued in Week 2 if over $99.99)

D Days

N Neither

O Overtime (hours)

R Regular (hours)

S Monetary (entered with dollars in the first week and cents in
the second week)

Data Type Table

$ Monetary (amounts not to exceed $99.99 are entered in
Week 1 and are continued in Week 2 if over $99.99)

D Days

N Neither

O Overtime (hours)

R Regular (hours)

S Monetary (entered with dollars in the first week and cents in
the second week)

Backup Options Table

T And A Data Only Only backs up T&A data.

Table Data Only Only backs up table data.

All Data Backs up both T&A and table data.

Select T_A Restore Type Table

Complete T_A Data Restores complete T&A data.

Partial T_A Data Restores T&A data for a particular employee for one pay period for a
particular contact point, for a particular employee for a particular contact
point, or for one pay period for a particular contact point. The contact point
is always required in Partial T_A Data. The pay period and employee are
optional depending on what data the user wishes to restore.

None Does not restore any T&A data.
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Select Table Restore Type Table

All Tables Restores all tables. Even if you select All Tables, you can only restore one
table at a time. You will be prompted for each individual table until all
tables are restored.

Selected Tables Restores a selected group of tables. You must designate the desired
tables. You will only be able to restore one table at a time. You will be
prompted for each individual table until all selected tables are restored.

None Does not restores any tables.

Work Schedule Table

Full Time Full Time Employee

Intermittent Intermittent Employee

Intermittent 6 An Intermittent Employee who substitutes for a Full-Time employee.

Part Time Part Time Employee

1st 40 Hours The first 40 hours of work performed in a week define the tour of duty for
that particular week.

Pay Plan Table

General
Schedule

General Schedule Pay Plan (e.g., GS, GW, GH, GM, etc.)

Wage Grade Federal Wage System Pay Plan ( e.g., WG, WL, WS, etc.

Other All other types of employee pay plans (e.g., ED, AD, YV, ES, EX, etc.

Special Type Table

Collaborators Record Overtime Hours Only

Fire Chief Biweekly Duty Hours Greater Than 80

Firefighter Biweekly Duty Hours Greater Than 80

Annual Leave Category Table

0 Not Eligible For Annual Leave

4 Less Than 3 Years Of Service

6 More Than 3, But Less Than 15 Years Of Service

8 More Than 15 Years Of Service
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Sick Leave Category Table

0 Not Eligible For Sick Leave

4 Eligible For Sick Leave

Leave Type Table

ANNL Annual Leave (includes donated, excludes restored)

AWOL Absence Without Leave

COMP Compensatory Leave

COMR Compensatory Leave-Religious

CRED Credit Leave

DONA Annual Leave Donated

DONR Restored Annual Leave Donated

FFAM Family Friendly Leave

FURL Furlough Leave

HOME Home Leave

INJU Injury Leave

LWOP Leave Without Pay

MILE Emergency Military Leave

MILR Military Leave Regular

OTHR Other Leave (administrative, funeral, jury, etc.)

PTUA Part Time Unapplied Annual Leave

PTUS

RSTR

Part Time Unapplied Sick Leave

Restored Annual Leave

SHOR Shore Leave

SICK Sick Leave (includes donated)

SUSP Suspension Regular

TOFF Time Off Award

Status Table

New Designates a new T&A for an employee. No data has been
entered on this T&A.

In Progress Designates a T&A that is in progress for an employee. This
T&A has not yet been verified.

Verified Designates a T&A that has been verified, but has not yet
been transmitted. Changes can still be made to this T&A.

Transmitted Designates a T&A that has been transmitted. Changes can
only be made to this T&A by preparing a corrected T&A.

In Error Designates a T&A that is in an error condition. This T&A can
not be verified or transmitted until the error condition is
corrected.
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AWS Table

(3) 4 10-Hr Days( ) y

(5) 8 9-Hr/1 8-Hr( )

(7) Variable Day In 40( ) y

(8) Variable Week In 80( )

(9) Return to Normal Schedule

Advance Leave Table

No Advanced Leave

A l LAnnual Leave

Sick LeaveSick Leave

Annual/Sick Leave

Type Of Employment Table (NFC Use)

Blank

Ft

N/A

Full Time Tour Change

In Intermittent Tour Change

Pt Part Time Tour Change

Accounting Data Usage Code Table

Blank Accounting on each line.

1 Store accounting on first line.

2 Use stored accounting.

Split T&A Table

Work Schedule Code (full-time, part-time, etc.)

C i D t Of S i YCommencing Date Of Service Year

Master Record NumberMaster Record Number

Individual Position Number
Pay Plan

O ti l S iOccupational Series

GradeGrade

Step
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Split T&A Table

Base Salary (Schedule Salary)

Salary Rate Code

Pay Rate Determinant Code

Save Grade Expiration Date
Duty Station

T Of D t HTour Of Duty Hours

Type Of Appointment CodeType Of Appointment Code

Special Employee Code
COLA/Post Differential Code

W B d Shift R tWage Board Shift Rate

Annuitant ShareAnnuitant Share

Cooperator Or State Share Of Salary
Hourly Cooperative Agreement Rates-Overtime

Hourly Cooperative Agreement Rates-Holiday

Quarters Deduction Code

Quarters Deduction Amount
FLSA Code

Employing Officey g

Extended LWOP effective other than Day 1, 2, 13, or 14 of the pay period.

Return to duty action effective other than Day 1, 2, 13, or 14 of the pay period.
Emergency military leave and/or AWOP used in the last pay period of the calendar
yearyear.

Nonpay status used the last pay period of the leave year.Non ay status used the last ay eriod of the leave year.

Regular military leave used during the pay period that covers the fiscal year split.

Report Preference Table

AD-321

Text

Prints the document in AD-321 format.

Prints the document in text format.
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Heading Index

This index provides an alphabetical list of all headings in the procedure. When a heading is referenced, you
can use this index to locate the page number.

A
About Employee Maintenance, 1

About STAR, 1

About T&A Maintenance, 9

About Tables, 35

Accounting
Biweekly T&A Window Field Instructions, 55
Restore Pop-up Field Instructions, 35

Accounting Code, 35

Accounting Code List Box, 40

Accounting Code List Window Field Instructions, 40

Accounting Code Rollover Pop-up Field Instructions, 41

Accounting Code Search Pop-up Field Instructions, 41

Accounting Code Selection List Pop-up Field Instruc-
tions, 56

Accounting Code Selection List Search Pop-up Field
Instructions, 56

Accounting Codes, 56

Accounting Data Usage Code, 60

Accounting Data Usage Code Table, 71

Accrue Flag, 43

Accrued
Employee Leave Account Window Field Instructions,

50
Leave Type List Window Field Instructions, 45

Acctg Rollover, 29

Adding A Leave Type To The Leave Type Table, 43

Adding Or Updating A Contact Point Record, 20

Adding Or Updating A Leave Type Record, 5

Adding Or Updating A Transaction Code, 40

Adding Or Updating An Accounting Code, 36

Adding Or Updating An Employee Record, 3

Adding/Removing A Contact Point(s) On The Selected
List, 24

Advance Leave, 59

Advance Leave Table, 71

Agency
Contact Point Maintenance Window Field Instructions,

28
Contact Point Search Pop-up Field Instructions, 30
Employee Window Field Instructions, 48

Annual Leave Category, 47

Annual Leave Category Table, 69

Annual Leave Ceiling, 48

Any Timekeeper Entry Flag, 30

Archive, 32

Archive List Box, 38

Archive Path Pop-up Field Instructions, 38

Archive Pop-up Field Instructions, 38

Archiving Data, 32

Arranging And Viewing Multiple Windows, 8

Athorized User List, 32

Authorized User List Window Field Instructions, 32

Authorized User Search Pop-up Field Instructions, 33

Automatic Backup, 29

Automatic Backup Directory Pop-up Field Instructions,
36

Available/ Selected List, 33

AWS
Biweekly T&A Window Field Instructions, 53
Update Header Pop-up Field Instructions, 59

AWS Table, 71

B
Backing Up Data, 26

Backup Options, 34

Backup Options Table, 68

Backup Path Pop-up Field Instructions, 34
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Backup Pop-up Field Instructions, 34

Backup/Restore, 26

Begin, 58

Begin Date, 57
Biweekly T&A Window Field Instructions, 53
Employee Leave Account Window Field Instructions,

49

Biweekly T&A Window Field Instructions, 53

Build JCL Window Field Instructions, 31

Building JCL, 21

C
Can Someone Enter Own Time, 30

Category
Accounting Code List Window Field Instructions, 40
Accounting Code Search Pop-up Field Instructions, 41
Accounting Code Selection List Search Pop-up Field

Instructions, 57

Change From, 41

Change To, 41

Changing A T&A, 15

City, 29

Clearing STAR Fields, 15

Collate, 51

Comment, 51

Comp Time Rollover, 29

Confirming The Transmission, 22

Contact Point
Employee Window Field Instructions, 48
Restore Pop-up Field Instructions, 35

Contact Point List
Contact Point List For Backup/Restore Processing

Pop-up Field Instructions, 33
Contact Point Maintenance Window Field Instructions,

28

Contact Point List For Backup/Restore Processing
Pop-up Field Instructions, 33

Contact Point List Window Field Instructions, 46

Contact Point Maintenance Window Field Instructions,
28

Contact Point Search Pop-up Field Instructions, 30

Contact Points, 19

Conversion Type, 33

Converting Data, 25

Copies, 51

Corrected Record, 57

D
Daily Biweekly Preference, 30

Data Conversion, 25

Data Conversion Window Field Instructions, 33

Data For JCL, 31

Data Type, 45

Data Type Table, 68

Date, Update Header Pop-up Field Instructions, 58, 59

Day, 58

Day Limitation, 48

Days Worked, 59

Defining Authorized Users, 22

Deleting Items In STAR, 15

Description, 44
Accounting Code List Window Field Instructions, 41
Accounting Code Search Pop-up Field Instructions, 41
Accounting Code Selection List Search Pop-up Field

Instructions, 57
Leave Type List Window Field Instructions, 44
Transaction Code List Window Field Instructions, 42

Detail
Biweekly T&A Window Field Instructions, 54
Contact Point Maintenance Window Field Instructions,

28
Employee Leave Account Window Field Instructions,

49
Leave Type List Window Field Instructions, 44
Transaction Code List Window Field Instructions, 42
Update Header Pop-up Field Instructions, 58

Dollar Amount, 57

Don’t Transmit User/ID Password, 32

E
Earned Used, 45

Employee
Archive Pop-up Field Instructions, 38
Biweekly T&A Window Field Instructions, 53
Employee Leave Account Window Field Instructions,

49
Restore Pop-up Field Instructions, 35
Time And Attendance List Window Field Instructions,

52
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Employee Leave Account Window Field Instructions, 49

Employee List
Employee List Window Field Instructions, 46
Time And Attendance List Window Field Instructions,

52

Employee List Window Field Instructions, 46

Employee Maintenance, 1

Employee Search Pop-up Field Instructions, 46

Employee Window Field Instructions, 47

Enabled, 43

Enabling Or Disabling A Transaction Code, 40

End, 58

End Date, 53

Enter Total Dollar Amount Pop-up Field Instructions, 57

Entry Approval Preference Flag, 30

Error, 64

Exiting STAR, 9

Export Path/File Name Pop-Up Field Instructions, 37

Exporting A File, 30

F
Field Instructions for Employee Maintenance, 46

Field Instructions for Getting Started in STAR, 27

Field Instructions for System Maintenance, 28

Field Instructions for T&A Maintenance, 52

Field Instructions for Tables Windows, 40

File List, 37

File Name
Open Pop-up For Import Field Instructions, 37
Open Pop-up For Restore Field Instructions, 36
Save Transmit File As Pop-up Field Instructions, 63

Files Of Type
Open Pop-up For Import Field Instructions, 38
Open Pop-up For Restore Field Instructions, 36

Final T&A, 58

First, 47

First (1st) Week, 59

Flag, 59

For SSN, 64

For SSN:, 62

Forward, 49

Fractions Of Hours Table, 67

G
Getting Started, 7

H
Hardware And Software Requirements, 3

I
Import/Export, 30

Import/Export Window Field Instructions, 37

Importing A File, 31

In Progress, 64

Init Forward, 44

J
JCL, 21

Job Card Comments, 31

Job Control Language, 32

Job Name, 31

L
Last Name

Employee Search Pop-up Field Instructions, 47
Employee Window Field Instructions, 47

Leave, 35

Leave Information, 47

Leave Type
Tables, 41
Transaction Code List Window Field Instructions, 43
Transaction Code Selection List Search Pop-up Field

Instructions, 56

Leave Type List Box, 44

Leave Type List Window Field Instructions, 44

Leave Type Search Pop-up Field Instructions, 44

Leave Type Table, 70

List Box, 64
Biweekly T&A Window Field Instructions, 54
Contact Point List Window Field Instructions, 46
Data Conversion Window Field Instructions, 33
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Employee Leave Account Window Field Instructions,
49

Open Pop-up For Restore Field Instructions, 36
Prepare Transmit File Window Field Instructions, 62
Restore Pop-up Field Instructions, 35
Save Transmit File As Pop-up Field Instructions, 63

Logging On, 8

Logon Pop-Up Field Instructions, 27

Long Name, 44

Look In
Open Pop-up For Import Field Instructions, 37
Open Pop-up For Restore Field Instructions, 36
Save Transmit File As Pop-up Field Instructions, 63

M
Maintaining A Header Record, 15

Maintaining Leave Accounts, 4

Max Balance, 44

Max PP:, 43

Merging T&A Records, 17

Middle, 47

N
Name

Biweekly T&A Window Field Instructions, 53
Employee Leave Account Window Field Instructions,

49
Print Window Field Instructions, 51
Time And Attendance List Window Field Instructions,

52
User Permissions Window Field Instructions, 32

New, 64

New Employee, 58

New Employee Pay Period Selection List Pop-up De-
scription, 48

New Password , 63

NFC Use, 60

Number, Update Header Pop-up Field Instructions, 57

Number of Copies, 51

O
Open As Read Only

Open Pop-up For Import Field Instructions, 38

Open Pop-up For Restore Field Instructions, 36
Save Transmit File As Field Instructions, 63

Open Pop-up For Import Field Instructions, 37

Open Pop-up For Restore Field Instructions, 36

Overview, 1

P
Part Time Information, 50

Part-T ime Unapplied Annual, 50

Part-T ime Unapplied Sick, 50

Password For NFC’s Mainframe, 63

Path, 34

Path And File Name
Archive Path Pop-up Field Instructions, 39
Export Path/File Name Field Instructions, 37

Pay Period, 41
Archive Pop-up  Field Instructions, 38
Biweekly T&A Window Field Instructions, 53
Employee Leave Account Window Field Instructions,

49
Restore Pop-up Field Instructions, 35
Update Header Pop-up Field Instructions, 57

Pay Period List Box, 43

Pay Period List Pop-up Field Instructions, 61

Pay Period List Window Field Instructions, 43

Pay Plan, 47

Pay Plan Table, 69

Payroll/Personnel Processing Cycle, 4

Percent (%) Premium, 60

Phone, 29

Prefix
Biweekly T&A Window Field Instructions, 54
Transaction Code List Window Field Instructions, 42
Transaction Code Selection List Search Pop-up Field

Instructions, 56

Prepare Transmit File Window Field Instructions, 61

Preparing A Corrected T&A, 17

Preparing A Split T&A, 16

Preparing A T&A, 10

Preparing Transmit For Pay Period, 62

Print Range, 51

Print Reports, 23

Print Reports Window Field Instructions, 63

Print Status, 64
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Print Stored Accounting, 64

Print Window Field Instructions, 51

Printer, 51

Printing Pay Period, 64

Printing T&A’s, 23

Printing The Open Window, 6

R
Record Retention Requirements, 2

Reference Tables, 67

Related Systems, 3

Remarks, 60

Remote Number, 31

Report Preference, 63

Report Preference Table, 72

Reporting, 8

Responsibilities, 5

Restore Pop-up Field Instructions, 34

Restoring Data, 27

Rolling Over An Accounting Code, 37

Rolling Over T&A’s, 18

Rollover Pop-up Description, 61

S
Save As Type, 63

Save Transmit File As Pop-up Field Instructions, 63

Searching For A Contact Point Record, 21

Searching For A Leave Type On The Table, 42

Searching For A Transaction Code, 39

Searching For An Accounting Code, 37

Searching For An Authorized User, 24

Searching For An Employee Record, 2

Second (2nd) Week, 59

Select T&A Restore Type, 34

Select T_A Restore Type Table, 68

Select Table Restore Type, 35

Select Table Restore Type Table, 69

Short Description, 43
Transaction Code Selection List Search Pop-up Field

Instructions, 56

Sick Leave Category, 48

Sick Leave Category Table, 70

Special Type, 47

Special Type Table, 69

Specify Path For Automatic Backup, 36

Split #, 53

Split Part 1 Begin Day, 61

Split Part 1 End Day, 61

Split Part 2 Begin Day, 61

Split Part 2 End Day, 61

Split T&A Information Pop-Up Field Instructions, 60

Split T&A Table, 71

Split/Part, 58

SSN
Biweekly T&A Window Field Instructions, 53
Employee Leave Account Window Field Instructions,

49
Employee Search Pop-up Field Instructions, 47
Employee Window Field Instructions, 47
Time And Attendance List Window Field Instructions,

52

St, 29

Standby/AUO/Avail Pay, 59

STAR Command Buttons, 11

STAR Functional/Directional Keys, 14

STAR Help, 7

STAR Menu Bar, 15

STAR Message Pop-ups, 14

STAR Operating Features, 9

STAR Pop-ups, 13

STAR Radio Buttons, 15

STAR Tool Bar, 10

STAR Users, 2

Starting STAR, 7

State
Contact Point Search Pop-up Field Instructions, 30
Employee Window Field Instructions, 48

State Code, 28

Status
Biweekly T&A Window Field Instructions, 53
Print Window Field Instructions, 51
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Update Header Pop-up Field Instructions, 58

Status Counts, 64

Status Table, 70

Stored Accounting, 60

Street 1, 29

Street 2, 29

Suffix
Biweekly T&A Window Field Instructions, 54
Transaction Code List Window Field Instructions, 42
Transaction Code Selection List Search Pop-up Field

Instructions, 56

System Access, 8

System Maintenance, 19

T
T and A, 63

T&A Maintenance, 9

T&A Restore Criteria, 35

T&A’s To Be Xmit’d; In, 62

Table List, 37

Table Restore Criteria, 35

Tables, 35

TC
Biweekly T&A Window Field Instructions, 54
Transaction Code Search Pop-up Field Instructions, 42
Transaction Code Selection List Search Pop-up Field

Instructions, 56

TC List Box, 55

TC Type Table, 68

Test/Prod, 31

Test/Prod Table, 67

Text, 64

There Are, 62

Time And Attendance List Window Field Instructions, 52

Timekeeper, 30

Timekeeper Code, 48

TK Number, 29

Top Flag, 43

Total Xmit T&A’s, 62

Tour of Duty, 47

Town
Contact Point Maintenance Window Field Instructions,

29
Contact Point Search Pop-up Field Instructions, 30
Employee Window Field Instructions, 48

Trans Code, 42

Transaction Code, 38

Transaction Code List Box, 42

Transaction Code List Window Field Instructions, 42

Transaction Code Search Pop-up Field Instructions, 41

Transaction Code Selection List Pop-up Field Instruc-
tions, 55

Transaction Code Selection List Search Pop-up Field
Instructions, 56

Transaction Codes, 35

Transmit Password Pop-up Field Instructions, 62

Transmit T&A’s, 19

Transmitting T&A’s, 20

Type, 51
Employee Leave Account Window Field Instructions,

49
Leave Type List Window Field Instructions, 44
Leave Type Search Pop-up Field Instructions, 44

Type Of Employment Table (NFC Use), 71

Type TC, 43

U
Unit

Contact Point Maintenance Window Field Instructions,
29

Contact Point Search Pop-up Field Instructions, 30
Employee Window Field Instructions, 48

Update Header Pop-up Field Instructions, 57

Use JCL, 62

Used, 50

User Id
Authorized User Search Pop-up Field Instructions, 33
Logon Pop-up Field Instructions, 27
Transmit Password Pop-up Field Instructions, 62
User Permissions Window Field Instructions, 32

User Permissions Window Field Instructions, 32

Using The Accounting Code Selection List Pop-up, 14

Using The Enter Total Dollar Amount Pop-up, 14

Using The Transaction Code Selection List Pop-up, 13
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V
Verified, 64

W
Wage Shift FEGLI, 59

Week 1 Hrs, 54

Week 2 Hrs, 54

Where, 51

Work Schedule, 47

Work Schedule Table, 69

X
Xmit, 64

Xmit Status, 62

Y
Year

Archive Pop-up Field Instructions, 38
Restore Pop-up Field Instructions, 35

Z
Zip, 29


